Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Yesterday, after having resized and moved some of my partitions I have successfully enlarged my Ubuntu partition but in the morning I wanted to launch the computer and ... one thing I get is the "blinking beacon".

I have tried booting into Ubuntu 12.04 USB and it worked, the disk is working - I can access it's files but I cannot boot into it.

I have tried using boot-repair but with the automated option I get no luck.

This is the link to it's log

Can anyone help me on this ?

I have been thinking on creating separate /boot partition in the beginning of the disk but I have some other Windows related partitions there (e.g. recovery partition) and this might be problematic.

EDIT After clicking Restore MBR in boot-repair I can boot but only to windows:/

Another boot-repair log


I have plugged in a USB stick in and installed my GRUB on it, then I was able to boot my Ubuntu (from hard drive) with GRUB from USB stick.

Now, since I already have access to my system - how can I repair/restore GRUB from here ? (or maybe even from anywhere else ) ?

share|improve this question
up vote 1 down vote accepted

From your booted Ubuntu install, run sudo grub-install /dev/sda.

While it's possible that you also have a buggy BIOS and need a separate /boot partition that is not what is causing the problem here (if that were the problem, you would still get a grub rescue shell rather than just a blinking cursor) and therefore I would recommend not creating a separate /boot partition (at least until you find that you really do have a buggy BIOS which can't properly handle large disks).

share|improve this answer
Ok so the problem was that somehow I have moved my first partition so that it would start in 19th sector instead of 63rd (I believe) and grub did not have enough place to install itself. Your answer is good but I needed to dig a little to figure this out and move my first partition a bit. – Patryk Aug 21 '12 at 12:00

These are 2 more boot recover options:

share|improve this answer

As indicated by Boot-Repair in its final window:

The boot files of [Ubuntu 12.04.1 LTS] are far from the start of the disk.
Your BIOS may not detect them. You may want to retry after creating a /boot
partition (EXT4, >200MB, start of the disk). This can be performed via tools
such as gParted. Then select this partition via the [Separate /boot partition:]
option of [Boot Repair]. (

If I were you, I would:

  1. backup documents on an external drive (or DVDs)
  2. via Gparted (included in Ubuntu CD) format the sda1 partition (labelled PQSERVICE) into EXT4.
  3. launch Boot-Repair, click Advanced options, go to the GRUB location tab, tick the Separate /boot partition: sda1 option, click Apply. Write the new URL on a paper (indicate it if any problem).
share|improve this answer
This is the option that I wanted to avoid :/ Will the option with separate partition appear when I create a new one/format existing into ext4 (3) ? Because now I cannot see this option in the boot-repair – Patryk Aug 20 '12 at 11:04
I think so. Boot-Repair doesn't propose separate /boot in NTFS. – LovinBuntu Aug 20 '12 at 21:37
Ok I have found that option when plugged a USB stick in. Please check my update. – Patryk Aug 20 '12 at 21:54

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.