Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Ubuntu 12.04 on my new Dell XPS 15 This one here. It has the Ivy bridge processor with an Nvidia card. I made the mistake of trying to install the nvidia proprietary driver. On reboot I got 640x800 resolution :-( So I apt-get remove --purge nvidia-current and it seems that the intel driver is now installed but I am stuck with 640x800.

Normally I would have booted using live cd (which has the correct resolution) and copy the xorg.conf from the live boot to the HDD. But this doesn't seem to work with 12.04.

I have added the Modes "1920x1080" to the xorg.conf file but with no luck

I have tried manually editing and also deleting the ~/config/monitors.xml with no luck

I tried installing Bumblebee with no luck

Oddly, if I plug an external monitor in the HDMI port, I can set the resolution correctly on that monitor.

If I do xrandr in a terminal with the live cd it finds the correct resolutions, but when I try it from the install, it only returns 640x800 :-(

I would like to get my resolution back to native. Any help would be greatly appreciated.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Remove the xorg config file and reboot.

Use bumblebee afterwards.

share|improve this answer
    
You're a champion. facepalm such a simple solution. Thanks –  Caustic Aug 19 '12 at 4:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.