Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This problem keeps coming back, no matter how many times I've killed it. I am seeing undesired versions of Japanese characters in my interface. (Particularly in Firefox, if that makes a difference).

For example, when looking at the word 七福神, it looks to me like this:

enter image description here

However, the characters should look like this (taken from another computer):

enter image description here

The difference is on characters two and three. In the top example They have on the left side, whereas in the bottom example, they have . I prefer to have the version that has , especially since that's the one used in modern Japanese (In fact, I have no idea why any font would bother using the version with for Japanese, or why such a font would be some kind of default in Ubuntu).

This exact problem is addressed in this question, but there are a few reasons why the solutions there don't apply anymore. One is that the accepted answer is for Ubuntu Natty 11.04, and the configuration interfaces shown don't seem to exist anymore in Ubuntu Pangolin 12.04. At least, not for me, using Gnome Classic. Another issue is that the accepted answer alternately suggests editing /etc/fonts/fonts.conf, but that file clearly says at the top DO NOT EDIT THIS FILE. IT WILL BE REPLACED WHEN FONTCONFIG IS UPDATED. I could not figure out what fontconfig is - it doesn't seem to be a program.

The most important issue is, that the ideal would be that when setting system fonts, what I want to do is be able to specify a default English font and a default Japanese font. The only place I've found to specify system fonts is here under System Tools -> Preferences -> Advanced Settings:

enter image description here

The problem is that it doesn't differentiate between English and Japanese font displays.

In other words, what is happening is that my default system font for most situations is Ubuntu. When a character can't be found in Ubuntu, which is almost certainly always the case when the character is Japanese, it defaults to some other font for Japanese that I can't find or control.

So, what I can do for now is switch all the default fonts to a Japanese one, but then I sort of have the opposite problem - the way a lot of Japanese fonts handle English characters kind of sucks. For example, I like the Meiryo font for Japanese, but it renders English characters so wide it's ridiculous.

Bottom line: How can I set a default font for English (such as Ubuntu), and then a default Japanese font (such as Meiryo) for when Ubuntu needs to render a Japanese character?

share|improve this question

1 Answer 1

up vote 5 down vote accepted
+50

Without manually messing with the fontconfig hierarchy, I think this just boils down to having the right subset of Japanese fonts installed.

For me, on a stock Ubuntu 12.04, installing the fonts-vlgothic Japanese package solved the problem. Could you try that?

  • Before (no extra fonts):

    enter image description here

  • After installing fonts-vlgothic:

    enter image description here


enter image description here

share|improve this answer
    
Well, that was an easy solution! I didn't even have to restart Firefox for the change to take hold, I just refreshed the page. –  Questioner Aug 23 '12 at 8:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.