Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Chromium doesn't seem to have any obvious MIME-type configuration settings, which strikes me as a little broken. My specific problem is that there are a number of filetypes that Chromium plays in-browser that I'd rather either download or associate with whatever my system-default MIME-type would suggest. Can this be done?

And here are two related (unanswered) questions, asking if there's a way to tell Chromium not to play mpeg video and mp3 files.

share|improve this question
add comment

1 Answer

Look at this ArchWiki entry in the section on File associations. To quote from there:

Unlike Firefox, Chromium does not maintain its own database of mimetype-to-application associations. Instead, it relies on Xdg-open to open files and other mime types, for example, magnet links. See Xdg-open for more information.

There are exceptions to this rule though. In the case of mailto URIs chromium calls out to xdg-email which is similar to xdg-open. Other protocol handlers may have equivalent scripts so check /usr/bin/xdg*. ...

share|improve this answer
1  
No - wait - Chromium is still broken for those mimetypes where it has some sort of builtin player (see related. My thought at first was something like "oh hey - xdg-mime query default audio/mpeg gives me totem.desktop and Chromium is somehow deciding that this means it should use its (disabled) Totem plugin to play these in-browser - so I changed to xdg-mime default banshee.desktop audio/mpeg but still get the obnoxious builtin player. Which, in the first place, all I want is to download the file rather than try to open it. –  Ternary Aug 23 '12 at 21:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.