Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

font looks bad in Browsers (Firefox and Chrome) All other applications as libreoffice look good. I'm using ubuntu 12.04

share|improve this question
    
You might need to install ms fonts packcage. refer this answer askubuntu.com/questions/166965/fonts-look-strange-in-firefox –  user106189 Nov 7 '12 at 11:39

3 Answers 3

up vote 2 down vote accepted

I was having a similar problem using Ubuntu 12.10. I did not realized that the problem started after I tried some dual screen configurations. When I went back to use just the Laptop Screen the resolution of the screen was set to 1360x786 pixels (there is such option) but my monitor has 1366x786 pixels. This 6 pixels difference has a minor impact on big fonts or pictures and etc... but the fonts in the browser are affected. Just set the resolution to match my screen native again and solved the problem.

share|improve this answer
    
I agree with user132869. I changed screen resolution and this problem is solved now. It was present only for browsers. Other apps were working properly. so you can also try doing that. –  CR2 Oct 14 '13 at 11:31

Have you tried other fonts? Go to Edit > Preferences. Firefox preferences

share|improve this answer
    
how to fix for Chrome? –  user60108 Aug 21 '12 at 1:16
    
Possibly use Chromium instead? Or stick to Firefox? I don't know I don't use Chrome. I think there's a wrench icon in the top right corner, try looking through that. –  captainjamie Aug 24 '12 at 23:04

Chrome fix 1: http://superuser.com/questions/726132/chrome-33-shows-ugly-blocky-pixelated-fonts-in-linux

Chrome fix 2: (official google fix) https://support.google.com/chrome/answer/95416?hl=en

and iirc you can edit the css-file in ~/.chrome/ or ~/.chromium/ somewhere, lost the thread to that fix. This enables you to change the standard font to your liking, altough websites that have defined another font as standardfont will still show you that font.

As for rendering, the above 2 fixes should be plenty and the bug that rendered blocky/pixelated fonts by default should be fixed since jan 2014. Update your chrome.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.