Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Failed to download repository information due to missing CDROM

I have been using Ubuntu for about 6 months now without any problems until I ran the update manager yesterday and kept getting this message:

 Failed to download repository information Check your Internet connection

Then in the more details box it reported:

W:Failed to fetch cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)/dists/precise/main/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
W:Failed to fetch cdrom://Ubuntu 12.04 LTS _Precise Pangolin_ - Release amd64 (20120425)/dists/precise/restricted/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs
E:Some index files failed to download. They have been ignored, or old ones used instead.

I have tried using the terminal commands given but have had no luck.

share|improve this question

marked as duplicate by jokerdino, LnxSlck, Anwar Shah, Jorge Castro, hexafraction Sep 21 '12 at 19:24

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

The update manager is looking for packages on the Ubuntu CD/DVD. If it is not inserted you get that error. You can disable the CD as package source. Open the software center, go to Edit/Software Sources... and disable the CD on the first tab.

share|improve this answer
    
thanks that did the trick can now update without error –  Adam Aug 18 '12 at 21:14
    
You're welcome :-) Since you seem to be new around here: Please mark my answer as solution. This way your question is marked as solved and others that might stumble upon it later can see that this was the solution (makes especially sense if there is more than one answer). Besides that I would get some reputation points ;-) –  André Stannek Aug 18 '12 at 22:51
    
For some reason, I don't have that option. Any ideas as to why? –  Oliver Joseph Ash May 31 '13 at 9:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.