Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have weired issue. I did a fresh installation of Ubuntu 12.04. Then I installed Nvidia drives for my graphics card. I executed the command "modprobe nvidia" after installing the Nvidia drivers and rebooted. After reboot, sound indicator in top panel is disabled and I can't control the volume from there. I opened Settings > Sound and it does not show any sound card installed. However, I can hear the sound. Please help.

Output of lspci | grep Audio

00:1b.0 Audio device: Intel Corporation N10/ICH 7 Family High Definition Audio Controller (rev 01)
01:00.1 Audio device: NVIDIA Corporation GF110 High Definition Audio Controller (rev a1)

Output of lsmod | grep snd

snd_hda_codec_hdmi     32191  4 
snd_hda_codec_realtek    73851  1 
snd_hda_intel          33367  0 
snd_hda_codec         134156  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13668  1 snd_hda_codec
snd_pcm                97188  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
snd_timer              29990  1 snd_pcm
snd                    78855  7 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer
soundcore              15091  1 snd
snd_page_alloc         18529  2 snd_hda_intel,snd_pcm
share|improve this question
add comment

1 Answer

My issue is resolved now. I was logged in with root. I logged out and logged in with another user and it worked.

share|improve this answer
    
Now your problem is solved, you should accept your own answer so future visitors can see this answer solved the problem. –  laurent Sep 16 '12 at 14:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.