Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I tested something in 12.04. I have Automatic login enabled with password. So When I login a window pops up asking for the password. But I tested the following. I clicked cancel twice in the pop up window so the window disappears for a while then I opened my Mozilla Firefox browser I went straight to Edit > Preferences > Saved passwords. I clicked show passwords and Voilá I had access all my account passwords without logging into Ubuntu.

Is this a bug or what? Is there a solution to make Ubuntu like in windows when a login screen comes up, I type my password than I access my desktop. It looks like that in Ubuntu the desktop and my files aren't blocked. Is there a solution to block everything while I type the password.

share|improve this question
2  
This is not a bug. Your passwords stored in Firefox have nothing to do with your user account under Ubuntu, which in turn has nothing to do with your root password. But there is an ongoing debate to move Firefox' password management to the Ubuntu wallet. Anywho, with auto-login enabled, everyone has access to your password wallet as well. –  con-f-use Aug 18 '12 at 15:21
add comment

2 Answers

The idea of Automatic Login is that it will not ask you for passwords during login. But anything that requires root user (aka admin) privileges, will not be possible and will still ask you for password confirmation. (Such installing new software, updating the system, etc...)

The password manager in Firefox has nothing to do with your Ubuntu account password. It only saves the passwords you save for websites.

As a suggestion, do not use the same password for everything. And if you want to type your password during login, you need to disable the automatic login.

Go into the User Accounts, in the top right there will be a Unlock button, click it and type your password and then disable the Automatic Login.

share|improve this answer
add comment

You can go insto System Settings, User Accounts and turn off automatic login in your account, then you'll be shown lightDM Loging Manager everytime you boot your Ubuntu instalation

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.