Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

My Lubuntu panel contains some running applets, but they are not arranged in order, and there is empty space between them. This particularly annoys me when using minimized windows.

Take a look at the image; that will explain what I'm trying to say:

enter image description here

I don't have it any more exactly like this, but I can't see the minimized windows on upper panel. I have created another upper panel and customized it as I need but my minimized windows are not displaying there either.

How can I sort my Panel?

share|improve this question
Are you using spacers? what are the contents of your panel applets in panel settings? – matt davis Aug 21 '12 at 14:09
i am not using any spacers between them . i am using application indicator , Weather Indicator ,Guake ,system monitor with sound applet . – Raja Aug 21 '12 at 14:16
ok that was selected and i have seen the changes too , but will it be saved or set back to previous case after restart .thank you . mention it as one answer . – Raja Aug 21 '12 at 16:07
It will be that way permanently. Any changes to that Panel Prefernces dialog should take immediate and permanent effect. – matt davis Aug 21 '12 at 16:11
Do you have other desktop environments installed, besides Lubuntu/LXDE? I think this may be a bug triggered by some other desktop environment. Something similar has been happening on multiple Lubuntu machines of mine, but only when I have other DE's installed as well. – Eliah Kagan Aug 24 '12 at 0:43

5 Answers 5

If that is the total contents of your panel then you need to add a "Task Bar(Window List)" from your Panel Preferences. This is the applet that will show your current windows. When you set it to the panel, check the box under the "Stretch" collumn. This will push everything to either side of it to the edge of your screen.

share|improve this answer
hey the changes are reverting back to normal after a restart . the solution you have given is good for after restart as a do task . thank you . – Raja Aug 22 '12 at 9:02
So the addition of the stretched Task Bar to your panel is a permanent solution to your problem? – matt davis Aug 22 '12 at 11:39
no man , the issue back again :( – Raja Aug 22 '12 at 13:06
So is the Task Bar (Windows List) gone after a restart? If so then it is not saving it's configuration. – matt davis Aug 22 '12 at 19:20
You may try 'sudo apt-get install --reinstall lxpanel' in terminal. Any changes to the Lxpanel should take permanent effect. If not, it would seem that it's corrupted somehow. – matt davis Aug 22 '12 at 19:36

This bug has been happening to me too. Please subscribe to the bug report on

share|improve this answer
i did that , thank you . – Raja Aug 27 '12 at 16:04

This video I did will help you:

And don't forget to add as the @mattdavis said the "Task Bar(Window List)" from the Panel Preferences > Panel Applets (tab) > Add (button).

To download it, use the following commands on the terminal:

  1. Install youtube-dl (command line YouTube video downloader):

    sudo apt-get install youtube-dl
  2. Run it on your terminal:

share|improve this answer
i am appreciating your help but my Internet very slow (20-25 KBPS) i cant watch it with that and its going to take huge time . – Raja Aug 27 '12 at 12:34
add FlashGot to Firefox and use FlasGot Media (ctrl-F7) to download and see it offline – cipricus Aug 27 '12 at 13:00
@GrSr The video has only 2MB. I edited the answer showing how to download it using the terminal. – Zignd Aug 27 '12 at 13:34
@GrSr I hope you get the video now using youtube-dl it's very light tool. – Zignd Aug 27 '12 at 13:38
Your answer is good up to adjust few applets like sound and clock but its not provided any option for adjusting those guake terminal ,weather indicator , sys monitor applet . Thank you but i have tried something and that worked for me .. – Raja Aug 27 '12 at 15:23
up vote 0 down vote accepted

ok after many trails on this issue . i did some progress . The first thing is delete the panel if it sounds bad , restart the panel .i did the process with only one panel.

ps -C lxpanel

Thats going to display the PID of lxpanel. Then we have to kill the lxpanel process .

kill <pid of the lxpanel>

then again in the terminal type as


Thats will do the restart of lxpanel with proper arrangement of the all panel elements.I need help about how to make it as script , because i am failing while getting the process ID and one more thing is to run the script all time , then only we can achieve this .

and one more thing about how to get minimized applets on the panel means we have to add a panel item " Task bar(window list) " panel item.then minimized windows will be in panel.

share|improve this answer
You can also just use lxpanelctl restart though it should be easy to script it. That might make it easier to script it, at any rate. Have fun. – KGIII Oct 17 at 18:49

On my LXLE 14.04: Right click on Task bar (Window list) > 'panel settings' (confusingly called "Panel preferences" in the pop-up) > check on tab 'Panel Applets' which applets have the Stretch parameter activated (or not).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.