Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed Open VPN. Both in my servers and in my computer. I see my log files as :

Aug 18 18:37:52 ubuntu openvpn[27920]: Local Options hash (VER=V4): 'bd6dea9e'
Aug 18 18:37:52 ubuntu openvpn[27920]: Expected Remote Options hash (VER=V4): '760316bb'
Aug 18 18:37:52 ubuntu openvpn[27931]: Attempting to establish TCP connection with x.x.x.x.x.x:80
Aug 18 18:37:52 ubuntu openvpn[27931]: TCP connection established with x.x.x.x:80
Aug 18 18:37:52 ubuntu openvpn[27931]: Socket Buffers: R=[87380->131072] S=[23860->131072]
Aug 18 18:37:52 ubuntu openvpn[27931]: TCPv4_CLIENT link local: [undef]
Aug 18 18:37:52 ubuntu openvpn[27931]: TCPv4_CLIENT link remote: x.x.x.x.x:80
Aug 18 18:37:52 ubuntu openvpn[27931]: WARNING: Bad encapsulated packet length from peer (15393), which must be > 0 and <= 1546 -- please ensure that --tun-mtu or --link-mtu is equal on both peers -- this condition could also indicate a possible active attack on the TCP link -- [Attemping restart...]
Aug 18 18:37:52 ubuntu openvpn[27931]: Connection reset, restarting [0]
Aug 18 18:37:52 ubuntu openvpn[27931]: TCP/UDP: Closing socket
Aug 18 18:37:52 ubuntu openvpn[27931]: /sbin/route del -net x.x.x.x.x. netmask 255.255.255.255
Aug 18 18:37:52 ubuntu openvpn[27931]: /sbin/route del -net 0.0.0.0 netmask 128.0.0.0
Aug 18 18:37:52 ubuntu openvpn[27931]: /sbin/route del -net 128.0.0.0 netmask 128.0.0.0
Aug 18 18:37:52 ubuntu openvpn[27931]: Closing TUN/TAP interface
Aug 18 18:37:52 ubuntu openvpn[27931]: SIGUSR1[soft,connection-reset] received, process restarting
Aug 18 18:37:52 ubuntu openvpn[27931]: Restart pause, 5 second(s)
Aug 18 18:37:57 ubuntu openvpn[27931]: Cannot open file key file 'ovpn.key': No such file or directory (errno=2)
Aug 18 18:37:57 ubuntu openvpn[27931]: Exiting

I wonder where is the problem, which makes VPN to reconnect. Note that the file ovpn.key is in the current directory!. But still its showing cannot open file error message.

Can anybody say me where I'm making mistake?

Thanks in advance.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted
  • Always reference you key with an absolute file name, not a relative one!

  • If it still doesn't work, check the file permissions.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.