Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have installed openvpn using the command :

sudo apt-get install  openvpn

After installing it, when I tried to start it, I get:

* Reloading virtual private network daemon(s)... 
 *   No VPN is running.

I'm very new to Ubuntu. I couldn't able to get what No VPN is running. meant. Does this mean any thing wrong in my installation?

I'm using 12.04 Ubuntu Version and since openvpn uses, tun/tap, I wonder its already installed in 12.04 versions?

Thanks in advance.

share|improve this question
    
Btw. with sudo apt-get install network-manager-vpnc you can easily install a graphical tool to configure your virtual private network connections from within the unity task bar. –  con-f-use Aug 18 '12 at 11:22
    
I have installed this, how do I open it? –  batman Aug 18 '12 at 11:42
    
That was just a remark for convenience. You don't really open it, you can find it with the network-manager tray icon, like in this picture: i.imgur.com/DJXkE.png –  con-f-use Aug 18 '12 at 11:49
    
Thanks for your reply. –  batman Aug 18 '12 at 12:00

1 Answer 1

up vote 2 down vote accepted

There's nothing wrong with your installation. You see this message because you haven't set up any VPN. You've installed the program, but you haven't yet set it up to be used. If you configure one or more VPN to automatically start at boot time, instead of this message, you'll see the nicknames of each VPN as it starts up.

share|improve this answer
    
oh! So how one could find the current running process in Ubuntu? So that I can check openvpn is running. . . –  batman Aug 18 '12 at 11:17
    
ps -A | grep -i vpn in shell would show you which processes are running that have "vpn" in their name. –  con-f-use Aug 18 '12 at 11:20
    
@batman If you haven't configured any VPN client or server, no openvpn process will run. First configure what you need, then run service openvpn start. –  Gilles Aug 18 '12 at 11:21
    
I tried sudo openvpn --proto tcp-client --remote x.x.x.x.x.x --port 80 --dev tun1 --secret ovpn.key --redirect-gateway def1 --ifconfig 10.4.0.2 10.4.0.1 --daemon. And then I issued the command : service openvpn start. And I tried with ps -A | grep -i vpn. I'm getting no output :( Very much confused! (Note that I have already installed openvpn in my server side. Which is the ip I'm passing as x.x.x.x) –  batman Aug 18 '12 at 11:39
    
Since I'm passing tun as network device. I tried this ifconfig tun1 But I get : tun1: error fetching interface information: Device not found error! –  batman Aug 18 '12 at 11:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.