Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a Samsung NP300E5A notebook with Nvidia Optimus. Following other answers, I installed Bumblebee and after some troubleshooting (followed https://github.com/Bumblebee-Project/Bumblebee/issues/220) I finally get this:

desktop:~$ glxinfo | grep OpenGL
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile 
OpenGL version string: 3.0 Mesa 8.0.2
OpenGL shading language version string: 1.30
OpenGL extensions:

desktop:~$ optirun glxinfo | grep OpenGL
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GT 520MX/PCIe/SSE2
OpenGL version string: 4.2.0 NVIDIA 304.37
OpenGL shading language version string: 4.20 NVIDIA via Cg compiler
OpenGL extensions:

optirun glxspheres 
Polygons in scene: 62464
Visual ID of window: 0x21
Context is Direct
OpenGL Renderer: GeForce GT 520MX/PCIe/SSE2

It seems OK then, but if I try to dim the screen (or if I go on batteries and it tries to do so automatically) it doesn't seem to be able to do it and almost freezes (eats up so much CPU that I cannot even shutdown properly).

In another forum I saw somebody with the same problem and no help (https://answers.launchpad.net/ubuntu/+source/xserver-xorg-video-nv/+question/205823)

Update: Following this (http://ubuntucomputing.blogspot.com.br/2011/10/how-to-fix-adjust-screen-backlight-of.html#comment-form) I improved it a litle by editing /etc/default/grub for

GRUB_CMDLINE_LINUX_DEFAULT="splash acpi_backlight=vendor" GRUB_CMDLINE_LINUX="acpi_backlight=vendor"

and runing 'update-grub'. However, now I can dim the screen but I cannot get it all the way up again!. Is it perhaps related to something different than bumblebee? (I do not know)

Any idea please please?

share|improve this question

2 Answers 2

Turn off optimus and run discrete graphics only. That seems to work for me using my lenovo W520.

share|improve this answer
    
Thank you. How do I do that definitely? (haven't found it) Now, with bumblebee, I think it is turned off when not used (if I run sudo cat /proc/acpi/bbswitch, I get "0000:01:00.0 OFF"), but I do not know if it gets turned on when I try to modify the brightness. –  hutxubix Aug 18 '12 at 7:58

I found another workaround that works. It is a little script that somebody wrote for Archlinux but works the same:

https://bbs.archlinux.org/viewtopic.php?pid=1148019#p1148019

Before this, I could only dim the screen. Now (using the terminal) I can light it up again :-)) Very happy!

In any case, I would like to know how to "embedd" this in the system, I mean, how can I modify ubuntu brithness control so that it makes the same that the script. Any ideas please?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.