Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed 12.04 successfully and rebooted (I took out my installation CD), and selected the newly installed Linux partition to boot from rEFIt. Then it just comes up with this error message:

Error loading operating system

which could not be more vague. Take that back. I guess it could say just "error." I don't even get to the boot prompt which limits what I can do. I cannot boot into rescue mode. I tried boot-repair, but it took more than 24 hours to check the system configuration, so I gave up on that.

I'm running a Mac Mini with its main OS being Mac OS X 10.5.8. I have an alternate OS Windows XP installed, which was virtually destroyed by this Linux installation. I sacrificed my working, speedy Windows partition for something that won't even boot up. What was I thinking. My Mac partition is slow as crap.

I've tried installing 12.04 many times with two different disks. The first time, I had one partition for Linux, then I had 2 (swap+main), then 3 (swap, main and BIOS), then 4 which is what I have now (swap, main, BIOS, and boot/grub).

The only way I could get through the install without GRUB giving up was if I created a separate partition for it. Which was pointless, because it did install successfully, but it still doesn't boot up at all.

Could rEFIt be booting off of the BIOS or one of the other partitions? Because if that's the case, there is no alternative, because Mac itself without rEFIt refuses to recognize a Linux ext4 (or 2 or 3) format partition. Apple always has to make everything so difficult. If I'm not mistaken, rEFIt is the only application of its kind for Mac.

I can boot off of the CD back to the install/try screen.

This is extremely upsetting, can you guys help? Please?

share|improve this question

1 Answer 1

I had the same problem. Below are the steps I used to solve it:

  • I changed BIOS setting to default.
  • Format "Linux Partition" and "Swap" using the Ubuntu live CD.
  • I changed the boot device to "Linux Partition"
  • Rebooted the machine, and removed the CD.
  • I ran the update to 12.04

Hope you can do the same.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.