Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having some trouble with wunderlist in ubuntu 12.04 64bit.

I followed the instructions on http://www.webupd8.org/2012/01/how-to-install-wunderlist-in-ubuntu.html and http://support.wunderlist.com/customer/portal/questions/63885-ubuntu-11-1-installation-?new=63885

It seemed to have installed on my system, the icon is available in my menu. However when I click to run the app it does nothing.

When I try to run the app through terminal with /opt/Wunderlist-1.2.4/Wunderlist

I get this response /opt/Wunderlist-1.2.4/Wunderlist: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

And that is where the files where installed in, unless I am doing it wrong?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Checking on one of my systems which package provide the shared library mentioned returns

$ dpkg -S /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0
libgtk2.0-0: /usr/lib/i386-linux-gnu/libgtk-x11-2.0.so.0

So you probably have to run

sudo apt-get install libgtk2.0-0

to install the shared library that wundelist complains missing...

Edit:
Turned out the link on the Wunderlist website points by default to the 32bit version of Wunderlist. On a 64bit system (as you have), it's better to use the 64bit version of Wunderlist, which is just a little bit hidden: https://s3.amazonaws.com/wunderlist/wunderlist-1.2.4-linux-64.tgz
Using this version and the method described in the links in your post, we got it working!

share|improve this answer
    
Will this affect my system in any way? –  Marchosius Aug 17 '12 at 21:08
    
Just ran the code and got the following libgtk2.0-0 is already the newest version. The following packages were automatically installed and are no longer required: libunistring0:i386 libgomp1:i386 libcroco3:i386 libgettextpo0:i386 Use 'apt-get autoremove' to remove them. 0 upgraded, 0 newly installed, 0 to remove and 7 not upgraded. –  Marchosius Aug 17 '12 at 21:09
    
Ok, so we need to dig a little deeper! You have to make sure that wundelist finds the library and that the library is of the right flavor (32bit). Please paste the output of ldd /opt/Wunderlist-1.2.4/Wunderlist and file /opt/Wunderlist-1.2.4/Wunderlist, if available –  ceage Aug 17 '12 at 21:22
    
Did you download the 64bit version of wunderlist? You are using a 64bit ubuntu 12.04 and the default link at the wunderlist website points to a 32bit version (at least for me). The 64bit link is here –  ceage Aug 17 '12 at 21:44
    
linux-gate.so.1 => (0xf7749000) libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf772a000) libgtk-x11-2.0.so.0 => not found libatk-1.0.so.0 => not found libgio-2.0.so.0 => /usr/lib/i386-linux-gnu/libgio-2.0.so.0 (0xf75d2000) libpangoft2-1.0.so.0 => not found libfreetype.so.6 => /usr/lib/i386-linux-gnu/libfreetype.so.6 (0xf7538000) libfontconfig.so.1 => /usr/lib/i386-linux-gnu/libfontconfig.so.1 (0xf7504000) libgdk-x11-2.0.so.0 => not found libgdk_pixbuf-2.0.so.0 => not found libpangocairo-1.0.so.0 => not found libpango-1.0.so.0 => not found –  Marchosius Aug 17 '12 at 21:54
show 13 more comments

Here is an alternative to installing Wunderlist:

First you will need to install Fogger. You can install it by clicking on the button below.

Install via the software center

Then you will need to go to this site and follow these instructions.

Hope this helps you!

share|improve this answer
    
Within the customization process they talk about a .js and a .css file, where do i get these files? i cant seem to find them? Edit - Scratch this, found it –  Marchosius Aug 17 '12 at 21:40
    
Just one thing, do I have any off line functionality with this method? –  Marchosius Aug 17 '12 at 21:50
    
I think you won't. What Fogger does, is get a website, and integrate it with the desktop. –  Max Tither Aug 17 '12 at 21:52
    
loading the website every time I want to use it could be a bit redundant at times, specialy when my connection is slow. –  Marchosius Aug 17 '12 at 21:59
    
Where will i be able to find info on how to remove a Fogger app I have made? I forgot to add the icon the setup and wish to redo the setup of it –  Marchosius Aug 17 '12 at 22:06
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.