Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to install gir1.2-gwibber-gtk-0.2, I get the following errors :

agmenor@ultimeextensaub:~$ sudo apt-get install gir1.2-gwibber-gtk-0.2
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:    
The following packages have unmet dependencies:
 gir1.2-gwibber-gtk-0.2 : Depends: libgwibber-gtk2 (= 3.4.2-0ubuntu2) but it is not going to be installed
                          Depends: gir1.2-gwibber-0.2 (= 3.4.2-0ubuntu2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

agmenor@ultimeextensaub:~$ sudo apt-get install libgwibber-gtk2
[…]
The following packages have unmet dependencies:
 libgwibber-gtk2 : Depends: libgwibber2 (>= 3.3.90) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

agmenor@ultimeextensaub:~$ sudo apt-get install libgwibber2
[…]
The following packages have unmet dependencies:
 libgwibber2 : Depends: gwibber-service (>= 2.31.1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

agmenor@ultimeextensaub:~$ sudo apt-get install gwibber-service
[…]
gwibber-service is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

The version of gwibber-service is gwibber-service 3.5.2+webaccounts4-0ubuntu1. I realize you may need more information : if you tell me what to post in the comments, I'll edit my question.

share|improve this question

1 Answer 1

up vote 3 down vote accepted

It appears you have installed a version of gwibber from a PPA which breaks the packages in Ubuntu.

The version of the API in the newer version is now 0.3, so if you install gir1.2-gwibber-gtk-0.3 instead, the install should work for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.