Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Most of the time I use Guake as terminal emulator. Today I wanted to start a program from gnome-terminal and it tells me that it's not installed currently, although I ran the program a minute ago on Guake.

When I echo $TERM, I get xterm on both, however echo $PATH in gnome-terminal differs. Does anyone know what this is about ?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

It's possible that you modified the $PATH in Guake. If you're able to run the program from Guake, copy $PATH and then use the following command in gnome-terminal:

export PATH=<path copied from Guake>

Now try to run the program. If you want it to remain the same permanently, put the above line in your ~/.bashrc file.

share|improve this answer
    
Yes, the $PATH in Guake was somehow modified, and now after restarting the computer I can not access the program from Guake either. I guess I'll have to figure out which directories to include in $PATH in order to be able to use it. Thank you for your answer. –  Maputo Aug 17 '12 at 17:46
1  
So here is what the problem was. The program I was trying to run was (ruby on) rails. When installed, it adds a line in .bash_login file to export path. However, .bash_login is not executed by default by Guake or gnome-terminal, because they don't run commands as a login-shell. In order to set gnome-terminal to run commands as a login-shell, check the Run command as a login shell checkbox at Edit/Profile Preferences/Title and Command. Same goes for Guake. For more on login and non-login shell: admon.org/difference-between-login-shell-and-non-login-shell –  Maputo Aug 17 '12 at 23:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.