Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to hook up my Ubuntu computer to my Plasma television.

I've recently installed Ubuntu 12.04 on an old Pentium 4 computer that has a standard VESA graphics card, running the default standard VESA graphics driver.

The computer runs fine when attached to a monitor using a VGA to VGA cord.

I've attached a VGA to RCA component cable (red,blue,green) from the computer to my Panasonic TH-42PA60A Plasma television.

The sound card is attached from the computer to the television using an audio-jack to RCA composite (Red, White Yellow) cord.

I receive absolutely no video signal on the television. It appears black. Unplugging the Sound-jack to RCA composite cable did nothing.

When I unplug the computer from the television, and plug it into the monitor using the VGA to VGA cable, without turning off the computer, Ubuntu appears on the monitor with this error ;

enter image description here

I've been informed that I may need to configure the xorg.conf file found at /etc/X11/xorg.conf since "monitors tell computers what they can handle, but that doesn't happen over a composite or component cable".

There was no such xorg.conf file in that directory, so I created one.

I've attempted using the following xorg.conf configuration code which I found on Ubuntu forums

Section "Device"
    Identifier    "Configured Video Device"
    Driver        "vesa"
EndSection

Section "Monitor"
    Identifier    "Configured Monitor"
    HorizSync 42.0 - 52.0 
    VertRefresh 55.0 - 65.0 
    Modeline "1024x768" 60.80  1024 1056 1128 1272   768  768  770  796
    Modeline "800x600" 38.21 800 832 976 1008 600 612 618 631
    Modeline "640x480" 24.11 640 672 760 792 480 490 495 50
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Monitor        "Configured Monitor"
    Device        "Configured Video Device"
    DefaultDepth    24
    Subsection "Display"
        Depth       24
        Modes       "1024x768" "800x600" "640x480"
       EndSubsection
EndSection

After reconnecting the computer to the television and then booting the computer up, I still receive no video signal, only a black screen.

When reconnecting the computer back to the monitor, a CRTC error is showing up on the screen again.

How can configure my xorg.conf file so that I can use Ubuntu on my Plasma television, and is there more, or different things that may need to be done?

The Plasma Television's Operating Instruction manual provided the following information relating to aspect ratios, frequencies and total specs ;

These are my Panasonic TH-42PA60A Plasma Televsion Specifications.

share|improve this question
1  
This After restarting the computer, and reconnecting the computer to the television implies that you boot the computer and thn swap the video cable. What happens if you just try to boot with the TV connected? Do you see the BIOS power on self-test messages? –  StarNamer Aug 17 '12 at 15:44
    
oh, sorry, no it should be the other way round. I reconnected the computer to the television, and booted up the computer. I'll edit it. Thanks. –  Mikelane Aug 17 '12 at 15:56
    
So you don't even get the BIOS output? If not, then you need to get that displayed before fixing Xorg. –  StarNamer Aug 17 '12 at 16:03
    
no, not even a BIOS output. Would I need to configure the BIOS first? If so, using the specifications in my question, are there any specific things I should take note of when configuring my BIOS? –  Mikelane Aug 17 '12 at 16:27
    
I suspect your VGA to RCA cable is RGB type. For your TV inputs, you need a VGA to RCA YPbPR cable. Unfortunately, the color coding for YPbPR connectors is also Red/Green/Blue the same as RGB cables. Can you check the specification of the cable? Changing anything in either the BIOS or the TV settings won't help. –  StarNamer Aug 18 '12 at 19:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.