Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing skype my dependencies are broken. I tried to run apt-get -f install but I only get error messages. I am running Ubuntu 12.04 on AMD64. If you need more informations please tell me.

The following packages have unmet dependencies:
libasound2-plugins:i386:
Depends: libjack-jackd2-0:i386 (>= 1.9.5~dfsg-14)
but it is not going to be installed or libjack-0.116:i386
Get:1 http://ppa.launchpad.net/dns/sound/ubuntu/ precise/main libjack-jackd2-0 i386 1.9.8~dfsg.2-1precise1 [202 kB]
Fetched 202 kB in 1s (105 kB/s)            

Unpacking libjack-jackd2-0:i386 (from .../libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb (--unpack):
 './usr/share/doc/libjack-jackd2-0/buildinfo.gz' is different from the same file on the system
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/libjack-jackd2-0_1.9.8~dfsg.2-1precise1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Thanks for help. Maybe its caused LMMS, but the problem appeared after installing skype. :)

share|improve this question
    
How do you installed skype? Is it from the official respositories? –  hzsolt Aug 17 '12 at 13:06
    
Possible duplicate: askubuntu.com/questions/127727/… –  Jorge Castro Feb 2 '13 at 22:37

3 Answers 3

Thanks for your support. I was able to fix it with:

sudo dpkg --remove libasound2:i386 libasound2-plugins:i386

I tried to install Skype over both ways (Software Center and Skype.com). Now I just run the +x from the official tarball.

share|improve this answer

Looks like a broken package. You'll need to remove libasound2-plugins. You might have to force it to remove, using this line sudo dpkg --remove -force --force-remove-reinstreq libasound2-plugins. (Here are a number of other commands that can help you clean up apt-get when it gets unruly.)

Skype, in their infinite wisdom, haven't bothered releasing a 64-bit version of their Linux client. Therefore, it depends on the 32-bit versions of everything that it depends on. So, you'll also need to do that.

To install the libraries, run apt-get install ia32-libs before installing Skype.

share|improve this answer

Ran into a similar issue with WINE for 32bit exes, on x64 Ubuntu 14.04. Support for 32-bit exes is provided by the multiarch :i386 wine, which depends on the :i386 multiarch versions of various non-WINE libraries.

(As I understand it, these :i386 packages are identical binaries to what Ubuntu i386 would use, saving space on mirrors, and saving build time since there is no need to build a 32bit-for-x64 version of anything. And of course letting you have the 32 and 64 bit version of pretty much anything installed side by side, so you can run any i386 Linux binary on an x64 system. As well as saving build time and mirror space, nobody needs to specifically package anything as 32bit-on-x64.)

wine1.6-i386:i386 1:1.6.2-0ubuntu4 recommends: libasound2-plugins:i386 (which I think is required for sound to work if another program has an open audio output stream, since this is where the alsa->pulseaudio module lives.)

libasound2-plugins:i386 1.0.27-2ubuntu2 depends: libjack-jackd2-0 (>= 1.9.5~dfsg-14) | libjack-0.116

Trying to install libasound2-plugins:i386 tries to pull in libjack-jackd2-0, which conflicts with libjack0. I have the x64 libjack0 installed already, so the package manager sees a conflict.

Unfortunately, apt doesn't realize that it could resolve the dependency by installing libjack0:i386 instead of libjack-jackd2-0:i386 to satisfy libasound2-plugins:i386's dependency. Manually selecting it lets me select libasound2-plugins:i386 without conflicts. (I used aptitude).

Yup, that got sound working for x86 apps (including wine) when pulseaudio is needed. At first I thought this was a packaging bug with something, but no, turns out it's just a bug in the dependency solver for multiarch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.