Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a fresh install of Ubuntu server edition running on my home server. I cannot (for the life of me) get it to boot with a second hard drive plugged in. I have checked boot priority and made sure that it is not trying to boot from the Hitachi 1TB drive. It is trying to boot from the 500GB drive with the install of Ubuntu. When the second drive is plugged in, it just sticks at a screen with a white dash. If I turn off the computer (By force, there is no way to turn it off yet) and unplug either the power or SATA to the second drive, the server boots within seconds of seeing GRUB. I am not sure what to do, I have tried reinstalling Ubuntu. I am not sure if this is a bug within Ubuntu. I am using the latest version of the server edition with all of the updates, etc. I have made sure all of my packages are updated.

share|improve this question
    
Have you checked the BIOS that it's seeing both drives and there isn't some conflict? –  StarNamer Aug 17 '12 at 13:34
    
Yes, I see both the Western Digital 500GB drive and the Hitachi 1TB drive. Both are recognized. It hangs at a dash after the grub menu. I had a copy of Windows on the 1TB drive before I needed more space on the server. I completely wiped the Hitachi before putting it in the server, making sure it was formatted using EXT4 with MBR. –  Austin Aug 17 '12 at 14:16
    
If you can get to the GRUB menu, have you tried booting recovery mode? Also, have you tried editing the startup to see/change which drive to use as root? It's possible that the device map has changed so GRUB sees the 500Gb drive as /dev/sda when it's alone but as /dev/sdb with the 1Tb as /dev/sda. The initial bootloader could load GRUB, which may then fail to load the kernel because it's reading the wrong disk -- I'd expect an error message is this situation, but it's still worth checking. –  StarNamer Aug 17 '12 at 15:35
    
Ok, I have tried what you said (using recovery mode) and it still doesn't do anything. I can still boot normal Ubuntu after the drive is unplugged, just not while plugged in. I do not see any errors in the log. I did notice after I did recovery mode and attempted to boot, it now sticks at a white dash and then after about 2 minutes I see "Loading Kernel" and then it goes back to the dash. I left it for 15 minutes after that, and it still didn't do anything. –  Austin Aug 17 '12 at 16:51
    
Your answer isn't clear. Did you get into recovery mode or not? Also, do either of the drives have speed setting jumpers? –  StarNamer Aug 18 '12 at 19:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.