Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well I have searched far and wide for some solutions but I decided to take all the problems I have had into one.

First I have a 27" Apple iMac (Late 2009 Release) running a intel i7, 4GB of RAM, and ATI Radeon HD 4850 card with the standard airport extreme 2 which is running MAc OS X Lion (10.7.4) I checked the hardware support and Ubuntu seems to be ok after some tweaking.

So here is what I did in the exact order based on some lengthy research.

First I downloaded rEFIt (version .14) and installed it. I did a quick halt and reboot and it work.

Next I wasn't sure whether to trust ubuntu to parition my main drive or handle it myself. So I decided to go for the self partitioning. Did you know that partitioning on Lion is not like partitioning on Leopard?

I ended up reparing the disk and rebooting into recovery mode and making the partitions there. I have a 1TB hard and I slipt it up as so (Approx.) MacOS = 575 Exfat(I called it Data) 350 and 75Gb Free Space.

Next I downloaded the 64 bit version of the newest ubuntu release Ubuntu 12.04.iso and burnt it to disk using the slowest write speed.

Next I inserted the disk and restarted the and held "C" it booted to from the CD and I was at the first menu in the Ubuntu phase. I first selected the Language then Install Ubuntu. Immediatly the screen went black but the disc was still reading. I immediatly realized this was Either a GUI issue or a Display issue. So I did some research and found out about the 'nomodeset' I did that and the install ran well. At least I thought. I restarted the Mac and waited for the EFI Boot menu or Grub menu. Nothing. So I shutdown and powered up again and this time held 'Alt' the menu came up and I selected the Windows Disk and then it went to the grub menu and I then had the choice again. I chose Ubuntu obviously. Purple screen popped up thenn! Command Line. I figured the disk failed and so I connected to my wifi and then proceed to update and then install the ubuntu desktop. I tried running the startX command but got nothing ESC and f6 failed me and so I shutdown. When i rebooted the mac goes straight to OS X. Its quit bothersome and I am surprise that this is this difficult. I suspect the Recovery Drive Lion create is to blame.

share|improve this question

3 Answers 3

Go to http://releases.ubuntu.com/raring/ and download the special mac version of the release. I just installed on a Macbook Pro 17" Late 2009 and it worked out of the box!

Also i suggest using rEFInd as rEFit is no longer in development. If you don not want to struggle with the EFI booting just add the hdbios option in your refind.conf file's scanfor line.

share|improve this answer

To install on Mac by CD , then Download the iso Version then Burn the iso file into the CD. After that restart your computer and boot it from the cd

share|improve this answer
1  
The OP has done exactly that. –  hexafraction Aug 17 '12 at 12:17
    
I did that. Thats not the problem the problem is Ubuntu Install screen (i.e. Where you chose to Install or try) comes up but as soon as I select something it goes black. I know its the fact that it switches to the display port but how can I fix this? –  paxsonsa Aug 18 '12 at 1:49

You're likely going to want to download the latest 13.04 version, I have had a lot of issues with 12.x series and proprietary video cards. So far 13.04 is working much better in this regard.

share|improve this answer
1  
I have 12.x running on MacBook, iMac and MacMini with no issues, so my experience is different to yours. Just thought I'd add that so user doesn't get a false impression. –  Meer Borg Jun 13 '13 at 10:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.