Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I purged the following packages by mistake. How do i reinstall them. Here are logs.

I was trying to Remove And Purge Orca Screen Reader.

Start-Date: 2012-08-17 07:16:01 Commandline: apt-get --purge remove orca*

Upgrade: python-ubuntuone-storageprotocol:i386 (3.0.0-0ubuntu1, 3.0.0-0ubuntu1.1), libcamel-1.2-29:i386 (3.2.3-0ubuntu6, 3.2.3-0ubuntu7), libpulse0:i386 (1.1-0ubuntu15, 1.1-0ubuntu15.1), python-ubuntuone-client:i386 (3.0.0-0ubuntu1, 3.0.1-0ubuntu1.0.1)
Purge: ubuntuone-client:i386 (3.0.0-0ubuntu1), ubuntuone-control-panel:i386 (3.0.0-0ubuntu1), gstreamer0.10-alsa:i386 (0.10.36-1), libpurple0:i386 (2.10.3-0ubuntu1), liborc-0.4-0:i386 (0.4.16-1ubuntu2), gir1.2-totem-1.0:i386 (3.0.1-0ubuntu21), python-gst0.10:i386 (0.10.22-3), unity-2d:i386 (5.10.0-0ubuntu1), libyelp0:i386 (3.4.1-0ubuntu1), gstreamer0.10-x:i386 (0.10.36-1), gnome-media:i386 (3.4.0-0ubuntu2), metacity:i386 (2.34.1-1ubuntu11), bluez-gstreamer:i386 (4.98-2ubuntu7), ubuntu-docs:i386 (12.04.4), gstreamer0.10-plugins-ugly:i386 (0.10.18.3-1ubuntu1), brasero-cdrkit:i386 (3.4.1-0ubuntu1), oneconf:i386 (0.2.8), libreoffice-calc:i386 (3.5.2-2ubuntu1), zenity:i386 (3.4.0-0ubuntu2), pulseaudio:i386 (1.1-0ubuntu15), libfolks-eds25:i386 (0.6.8-2), gir1.2-ubuntuoneui-3.0:i386 (3.0.0-0ubuntu1), libreoffice-gnome:i386 (3.5.2-2ubuntu1), totem-plugins:i386 (3.0.1-0ubuntu21), rhythmbox:i386 (2.96-0ubuntu4), ubuntu-sso-client:i386 (3.0.0-0ubuntu1), gnome-control-center:i386 (3.4.1-0ubuntu1), python-ubuntuone-control-panel:i386 (3.0.0-0ubuntu1), ubuntu-desktop:i386 (1.267), libreoffice-emailmerge:i386 (3.5.2-2ubuntu1), libreoffice-core:i386 (3.5.2-2ubuntu1), gstreamer0.10-plugins-bad-multiverse:i386 (0.10.21-1), libtotem0:i386 (3.0.1-0ubuntu21), libavcodec-extra-53:i386 (0.8.3ubuntu0.12.04.1), ubuntuone-client-gnome:i386 (3.0.0-0ubuntu1), gstreamer0.10-plugins-good:i386 (0.10.31-1ubuntu1), libavformat53:i386 (0.8.3-0ubuntu0.12.04.1), libreoffice-writer:i386 (3.5.2-2ubuntu1), libreoffice-draw:i386 (3.5.2-2ubuntu1), unity-scope-musicstores:i386 (5.10.0-0ubuntu1), shotwell:i386 (0.12.2-0ubuntu2), libdmapsharing-3.0-2:i386 (2.9.14-1), rhythmbox-mozilla:i386 (2.96-0ubuntu4), software-center:i386 (5.2), libsyncdaemon-1.0-1:i386 (3.0.0-0ubuntu1), libschroedinger-1.0-0:i386 (1.0.11-1), rhythmbox-plugin-zeitgeist:i386 (2.96-0ubuntu4), libwebkitgtk-3.0-0:i386 (1.8.0-0ubuntu2), gir1.2-webkit-3.0:i386 (1.8.0-0ubuntu2), ubuntu-sso-client-gtk:i386 (3.0.0-0ubuntu1), libreoffice-base-core:i386 (3.5.2-2ubuntu1), gnome-orca:i386 (3.4.0-0ubuntu2), gstreamer0.10-ffmpeg:i386 (0.10.13-1), rhythmbox-plugin-cdrecorder:i386 (2.96-0ubuntu4), telepathy-haze:i386 (0.6.0-0ubuntu1), libubuntuoneui-3.0-1:i386 (3.0.0-0ubuntu1), librhythmbox-core5:i386 (2.96-0ubuntu4), libreoffice-help-en-us:i386 (3.5.2-2ubuntu1), python-uno:i386 (3.5.2-2ubuntu1), libreoffice-style-human:i386 (3.5.2-2ubuntu1), sessioninstaller:i386 (0.20+bzr123-0ubuntu2), pulseaudio-module-bluetooth:i386 (1.1-0ubuntu15), libtelepathy-farstream2:i386 (0.4.0-0ubuntu1), gstreamer0.10-pulseaudio:i386 (0.10.31-1ubuntu1), pulseaudio-module-x11:i386 (1.1-0ubuntu15), gnome-online-accounts:i386 (3.4.0-0ubuntu1), libgoa-1.0-0:i386 (3.4.0-0ubuntu1), gnome-user-guide:i386 (3.4.1-1), apturl:i386 (0.5.1ubuntu3), libreoffice-impress:i386 (3.5.2-2ubuntu1), indicator-datetime:i386 (0.3.94-0ubuntu2), nautilus-share:i386 (0.7.3-1ubuntu2), gstreamer0.10-plugins-bad:i386 (0.10.22.3-2ubuntu2), evolution-data-server:i386 (3.2.3-0ubuntu6), rhythmbox-plugins:i386 (2.96-0ubuntu4), libgstreamer-plugins-bad0.10-0:i386 (0.10.22.3-2ubuntu2), python-ubuntu-sso-client:i386 (3.0.0-0ubuntu1), gimp:i386 (2.6.12-1ubuntu1), libbrasero-media3-1:i386 (3.4.1-0ubuntu1), rhythmbox-ubuntuone:i386 (3.0.0-0ubuntu1), yelp:i386 (3.4.1-0ubuntu1), gir1.2-rb-3.0:i386 (2.96-0ubuntu4), libreoffice-math:i386 (3.5.2-2ubuntu1), pulseaudio-module-gconf:i386 (1.1-0ubuntu15), indicator-sound:i386 (0.8.5.0-0ubuntu2), libcanberra-pulse:i386 (0.28-3ubuntu3), libmjpegtools-1.9:i386 (1.9.0-0.5ubuntu7), brasero:i386 (3.4.1-0ubuntu1), libreoffice-common:i386 (3.5.2-2ubuntu1), libwebkitgtk-1.0-0:i386 (1.8.0-0ubuntu2), libquicktime2:i386 (1.2.3-4build2), totem:i386 (3.0.1-0ubuntu21), gstreamer0.10-plugins-base:i386 (0.10.36-1), indicator-power:i386 (2.0-0ubuntu1), libgstreamer-plugins-base0.10-0:i386 (0.10.36-1), libfarstream-0.1-0:i386 (0.1.2-0ubuntu1), totem-mozilla:i386 (3.0.1-0ubuntu21), libreoffice-style-tango:i386 (3.5.2-2ubuntu1), libreoffice-gtk:i386 (3.5.2-2ubuntu1), rhythmbox-plugin-magnatune:i386 (2.96-0ubuntu4)
share|improve this question
    
Curious. How does ubuntuone-client fit to orca* template? –  Ivan Aug 17 '12 at 11:36
    
I don't Know. That's why it ruined my system. –  BigSack Aug 17 '12 at 11:38
    
This is from logs, so its correct. Please help me to fix this –  BigSack Aug 17 '12 at 11:39

2 Answers 2

up vote 3 down vote accepted

Looks like apt-get's wildcard search is broken! I tried some simulations (-s option).

I tried sudo apt-get -s --purge remove orca* and it said it wanted to remove 84 packages.

I tried sudo apt-get -s --purge remove orc* and the number went up to 1446.

I tried sudo apt-get -s --purge remove orcaa* and the list was 'gnome-orca' and 'ngorca'.

I'd agree with the suggestion to reinstall ubuntu-desktop and then test the wildcard search with option -s to give you a list of what it's going to do before it does it.

Now, where the bug report address for the apt-get maintainers... :)


While logging the bug report, I realised that the match is a regex (regular expression) hence '*' means zero or more of the preceeding character. orcaa* works becuase is 'o','r','c','a' followed by zero or more 'a' characters so the 'a*' serves simply to flag it as a regex search rather than an exact match. Canonically, it should probably be '.*' meaning zero or more of any character.

Your match, 'orca*', matches anything with 'o','r','c' followed by zero or more 'a' characters hence you get a lot more packages. For example, it matched liborc-0.4.0 which would have forced anything depending on that to be removed as well. apt-get may also have removed other items which were installed to satisfy dependencies and are no longer required.

(PS: it's not a bug!)

share|improve this answer

You should be able to get back to a sane place by reinstalling ubuntu-desktop.

It's probably going to reinstall orca though :)


To chroot in and restore this from a LiveCD:

  1. Boot to a LiveCD and click Try.
  2. Set up your network connection. You're going to need it.
  3. Open a terminal. The rest of this is terminal driven.
  4. Work out what the /dev/sdXY path is to your real partition with:

    sudo fdisk -l
    
  5. Mount that under /mnt (change XY to what you found in #4):

    sudo mount /dev/sdXY /mnt
    
  6. Cross-mount some of the running things (so the chroot has live access to hardware):

    for i in /dev /dev/pts /proc /sys /run; do sudo mount -B $i /mnt$i; done
    
  7. Chroot in like a ninja!

    sudo chroot /mnt
    
  8. Fix everything!

    sudo apt-get install ubuntu-desktop
    
share|improve this answer
    
Will this need Internet? Or some way to do it from ISO or something offline? –  BigSack Aug 17 '12 at 15:08
    
Yeah you'll need an internet connection. If you can't get one of those, you can boot to a LiveCD, start an internet connection from that session, open a terminal, chroot to the actual installed system and then use sudo apt-get install ubuntu-desktop to get things back to normal. –  Oli Aug 17 '12 at 15:12
    
An alternative may be to boot holding SHIFT down so you get to the GRUB menu and boot into the recovery system. Then you should be ale to drop to a root terminal session and just do the install from there. –  StarNamer Aug 17 '12 at 15:48
    
Yup, all depends on how your internet connection is made. It might seem weird, but it's easier (in my experience) to boot to a LiveUSB, chroot a live system and handle the internet connection graphically than it is to connect to a wireless network from the rescue root prompt. –  Oli Aug 19 '12 at 20:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.