Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Nvidia GeForce 9800 GT card and suddenly after some recent updates on 12.04, I am unable to get my resolution higher than 1024x768. It used to be 1440x900. I have tried uninstalling and reinstalling the Nvidia drivers several times and ways, and still have not found any solution. My current driver version is 295.49 and it says my display is a CRT. I don't understand why it thinks I have a CRT. My monitor is a Samsung SyncMaster 940BW. Any help would be greatly appreciated. Thanks in advance!

UPDATE: I have a second computer that has now done this on the same monitor and it has a different graphics card. The second computer was affected immediately after applying the most recent updates for 12.04. Could this just be a bug in one of the updates? Are others experiencing similar problems with different types of graphics cards? Just a thought.

Also, on the first computer (Nvidia) I did a complete reinstall. The best I could get was 1024x768 after installing the Nvidia current drivers. I held off on updating the computer to see if I could get a higher resolution but I couldn't. Then I updated the fresh install with the latest 12.04 updates and now I can only get a resolution of 640x480. Any ideas? Both systems are running 12.04 64 bit.

Also, after the reinstall I'm currently running 295.40 version.

XRandR output:


$ cvt 1440 900 60
# 1440x900 59.89 Hz (CVT 1.30MA) hsync: 55.93 kHz; pclk: 106.50 MHz
Modeline "1440x900_60.00"  106.50  1440 1528 1672 1904  900 903 909 934 -hsync +vsync

$ xrandr xrandr: Failed to get size of gamma for output default Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480 default connected 640x480+0+0 0mm x 0mm 640x480 50.0* 320x240 51.0

$ xrandr --newmode "1440x900_60.00" 106.50 1440 1528 1672 1904 900 903 909 934 -hsync +vsync xrandr: Failed to get size of gamma for output default

$ xrandr xrandr: Failed to get size of gamma for output default Screen 0: minimum 320 x 240, current 640 x 480, maximum 640 x 480 default connected 640x480+0+0 0mm x 0mm 640x480 50.0* 320x240 51.0
1440x900_60.00 (0x177) 106.5MHz h: width 1440 start 1528 end 1672 total 1904 skew 0 clock 55.9KHz v: height 900 start 903 end 909 total 934 clock 59.9Hz

$ xrandr --addmode default 1440x900_60.00 xrandr: Failed to get size of gamma for output default

$ xrandr --output default --mode 1440x900_60.00 xrandr: Failed to get size of gamma for output default xrandr: screen cannot be larger than 640x480 (desired size 1440x900)

xorg.conf:


$ cat /etc/X11/xorg.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 295.40  (buildmeister@swio-display-x86-rhel47-06.nvidia.com)  Thu Apr  5 22:40:54 PDT 2012

Section "ServerLayout" Identifier "Layout0" Screen 0 "Screen0" 0 0 InputDevice "Keyboard0" "CoreKeyboard" InputDevice "Mouse0" "CorePointer" EndSection

Section "Files" EndSection

Section "InputDevice"

# generated from default
Identifier     "Mouse0"
Driver         "mouse"
Option         "Protocol" "auto"
Option         "Device" "/dev/psaux"
Option         "Emulate3Buttons" "no"
Option         "ZAxisMapping" "4 5"

EndSection

Section "InputDevice"

# generated from default
Identifier     "Keyboard0"
Driver         "kbd"

EndSection

Section "Monitor" Identifier "Monitor0" VendorName "Unknown" ModelName "Unknown" HorizSync 28.0 - 33.0 VertRefresh 43.0 - 72.0 Option "DPMS" EndSection

Section "Device" Identifier "Device0" Driver "nvidia" VendorName "NVIDIA Corporation" EndSection

Section "Screen" Identifier "Screen0" Device "Device0" Monitor "Monitor0" DefaultDepth 24 SubSection "Display" Depth 24 EndSubSection EndSection

share|improve this question

4 Answers 4

If the xorg file exists, remove that and reboot.

sudo rm /etc/X11/xorg.conf

share|improve this answer
    
Removing the config file didn't work either. –  user83851 Aug 17 '12 at 19:28

Have you tried using nvidia-xconfig (after deleting xorg.conf)? Are you setting the resolution in the nvidia x server config utility or through ubuntu's display settings?

share|improve this answer
    
I tried removing the xorg.conf then using the nvidia-xconfig and still nothing. The xorg.conf that it generates is posted above. I've tried setting the resolution both ways and neither will work. Both say that 640x480 are the max. The ubuntu display says that the screen is a laptop (which it's not) and the nvidia display shows that I have a CRT (which I don't). The nvidia config panel shows CRT-0 on GPU-0 as my display model. –  user83851 Aug 17 '12 at 20:28

You can try this:

What you can do is install a newer version of the Nvida Drivers. Click the link below to download the latest drivers from Nvidia's Website:

Linux x64 (AMD64/EM64T) Display Driver

Download it and now follow this this tutorial on how to install it. I would suggest you read all this on another computer, as the one that you will perform the install on will not be working for internet viewing.

After you are done, try again to change your resolution.

Good Luck. Hope this works for you! Let me know if it works.

share|improve this answer
    
I've tried that with no luck. For some reason Nvidia thinks I have a CRT but I really have an LCD. I don't know how to fix that. –  user83851 Aug 17 '12 at 5:32
    
You could try this out: open the terminal and tye sudo add-apt-repository ppa:ubuntu-x-swat/x-updates sudo apt-get update sudo apt-get install nvidia-current. Now just reboot sudo reboot. After that, see if you can now change your settings. Hope this helps –  Max Tither Aug 17 '12 at 5:40
    
Still no luck. I do have 304.37 up and running successfully but I can only get 640x480. It's lower because I tried using nomodeset on boot and it didn't work so I removed it. Since I removed it, I can't get it any higher than 640x480 now. Any other ideas? It still seems to think I have a CRT rather than an LCD. Any ideas there? –  user83851 Aug 17 '12 at 6:30
    
No luck with that one either. I really appreciate the time you're taking to help me out. It's driving me crazy! This 12pt font is about 30pt font! –  user83851 Aug 17 '12 at 20:24
    
Do you know what your old driver number was –  Max Tither Aug 17 '12 at 20:26

I had the same problem and this is how I fixed it. Go to screen resolution then advanced settings once there click properties, next click on the tab called "driver" then "Roll back driver" 1440x900 should be an option now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.