Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated (August 16) Ubuntu 12.04 today and while I admit I didn't look what was being updated, it was large enough to have had an NVidia update in it. Problem is later on when I turned on my laptop again it won't boot into a GUI, just to the terminal (which I don't really know much of how to do anything). Now I have been able to log in and type "startx" to start up the GUI and now its complaining that my NVidia driver (if I remember correctly) is listed as being version 304.(number) and the version installed/found is version 295.(number). I don't know how this happened and now I'm stuck. I have no idea how it happened and don't know how to fix.

Does anyone have any ideas? I have only access to wifi internet and no idea how to log on without the GUI so getting a new NVidia package isn't something I would know how to do even... Any and all help would be highly appreciated.

edit: If it helps, I'm using a ASUS G Series G53JW-A1 http://www.newegg.com/Product/Product.aspx?Item=N82E16834220861

share|improve this question

1 Answer 1

The only way to get the 304 version of the driver is to download it from Nvidia's website, and then do a manual install. Now, the options are: 1.reinstall the 304 driver, or 2.remove it and use the one provided by Ubuntu.

1) To remove everything Nvidia related from the repositories, run

sudo apt-get purge nvidia* && sudo apt-get autoremove

... then run the manual installer you've downloaded from Nvidia.

2) To uninstall the manually installed driver, use the downloaded installer to run

sudo sh NVIDIA* --uninstall

...then

sudo apt-get purge nvidia* && sudo apt-get autoremove

...then reboot, and if you get the GUI, use the Additional Drivers utility. If not, run

sudo apt-get install nvidia-current
share|improve this answer
    
I don't know how to do that though from the terminal and a wireless internet only. I've tried looking up how to log onto a wireless from the terminal with no avail and I have tried to figure out how to mount either another (Windows) partition or USB and still can't. While its great you have made a nice and clear answer that I should be able to follow easily, I am still stuck either downloading and copying the file over from Windows or even just using apt-get with a wireless connection, neither is something I can do at the moment. I would prefer the internet option since apt-get is easy for me –  Xatolos Aug 17 '12 at 5:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.