Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm attempting to add/install MailScanner to my ubuntu 11.10 desktop configuration running postfix. I tried installing the latest 12.04 LTS but it had neither MailScanner nor qpopper package, 11.10 has qpopper so this is the release I went with.

I went to the MailScanner web site and reviewed the information here , I then went to and got the version from here .

Well I tried to follow the instructions from the first link but the MailScanner Package installed a series of configuration files with the suffix of dpkg-new sprinkled throughout the install. Running dpkg -c mailscanner_4.79.11-2.2_all.debshows the files but without this suffix. I'm new to linux and I've clearly missed something but I'm not sure what.

Does anyone know what the best way to get MailScanner installed on 11.10. I'm aware that the MailScanner package is available for 10.10 and 10.04 but I'd like to run a release that's a bit newer.

share|improve this question

Use the Baruwa repo [] simple and easy

cat > /etc/apt/sources.list.d/baruwa.list << 'EOF'
deb oneiric main
wget -O - | apt-key add -
apt-get update
apt-get install mailscanner
share|improve this answer

Okay I've solved my problem. I took the generic MailScanner files listed as "Version 4.84.5-2 for Solaris / BSD / Other Linux / Other Unix" and run the provided.

I then pulled down the init.d file for Debian Linux package. I had to tweak the init.d file and run update-rc.d a bit. Once that was done I followed the instructions from here and tweaked the paths and permissions as needed.

Mail is going in and out with no errors recorded in /var/log/mail.err. Received mail has what looks to be the correct MailScanner message inserted in the header.

share|improve this answer

as you mentioned there is a .DEB file . you can install .DEB file by using

sudo dpkg -i mailscanner_4.79.11-2.2_all.deb

Thats will installs .deb file . one more thing to install is to opening it with the Ubuntu Software center .

Hope that helps .

share|improve this answer
Hello; I've done the install using that command but it left the config files with a dpkg-new suffix and MailScanner won't start up. I started to edit the names of the files but it looks as if the post install config never ran. For example the rc#.d scripts were missing and I had to run update-rc.d. Is there a missing step? – John Gray Aug 17 '12 at 3:44
hi that page have good information . ok could provide us what you have entered and what you got . – Raja Aug 17 '12 at 3:53
I entered exactly what was in the page. I got a series of MailScanner configuration files that have a .dpkg-new sufix. Attempting to start MailScanner generates errors. It also is breaking the dependency maps for ubuntu's software updater. It's requesting a newer version of perl and complaining about the version installed. I had to remove Mailscanner to fix that software updater issues. – John Gray Aug 17 '12 at 4:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.