Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to setup my Samsung syncmaster B2030 monitor in ubuntu 12.04. It's native resolution is 1600x900 which I am not getting in ubuntu and which I am trying to get.

I tried using xrandr approach provided in these urls: 1) http://www.ubuntugeek.com/how-change-display-resolution-settings-using-xrandr.html 2) How to set the monitor to its native resolution which is not listed in the resolutions list?

S1) I used

cvt 1600 900 60

to get the modeline. Output was:

# 1600x900 59.95 Hz (CVT 1.44M9) hsync: 55.99 kHz; pclk: 118.25 MHz
Modeline "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

S2) I then used

xrandr

and output was:

Screen 0: minimum 8 x 8, current 1152 x 864, maximum 8192 x 8192
DVI-I-0 disconnected (normal left inverted right x axis y axis)
VGA-0 connected 1152x864+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
1024x768       60.0 +
1360x768       60.0     59.8  
1152x864       60.0* 
800x600        72.2     60.3     56.2  
680x384       119.9    119.6  
640x480        59.9  
512x384       120.0  
400x300       144.4  
320x240       120.1  
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)

which gave me "VGA-0".

S3) Then I used

xrandr --newmode "1600x900_60.00"  118.25  1600 1696 1856 2112  900 903 908 934 -hsync +vsync

But instead of adding the modeline it just threw an error:

X Error of failed request:  BadName (named color or font does not exist)
  Major opcode of failed request:  153 (RANDR)
  Minor opcode of failed request:  16 (RRCreateMode)
  Serial number of failed request:  29
  Current serial number in output stream:  29

My system details:

1) ubuntu 12.04 LTS

2) Graphic card: GeForce 9400 GT/PCIe/SSE2 (driver is successfully installed. I am checking it in System Settings > Details. And it's showing that driver is installed and its "GeForce 9400 GT/PCIe/SSE2")

3) Monitor: Samsung syncmaster B2030

4) Resolutions I am getting:

800x600
1024x768
1152x864 (I am currently using this one)
1360x768 (this one isn't working properly)

Does anyone know what I can do?

Thanks in advance.

UPDATE (1):

Today I tried it again. And adding a modeline (using --newmode) worked. But when I used --addmode by:

xrandr --addmode VGA-0 1600x900_60.00

It gave this error:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  153 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  29
  Current serial number in output stream:  30
share|improve this question
add comment

1 Answer 1

BadName means it interprets the .00 as special characters. Simply change the name of the new mode by removing everything after the decimal and appending a single letter or maybe try VGA. Note there are double quotes around the newmode name, but not when adding it to a specific output nor setting the mode of the monitor.

$ cp off your xorg.conf file just in case. $ xrandr --newmode "1600x900_60VGA" 118.25 1600 1696 1856 2112 900 903 908 934 -hsync +vsync $ xrandr --verbose --addmode VGA-0 1600x900_60VGA $ xrandr --verbose --output VGA-0 --mode 1600x900_60VGA

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.