Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I just installed mate. It seems so windows98'ish and I cannot change the screen resolution. I change it to 1280x960 and it shows that it's changed but it doesn't change and resolution is still the same.

I have installed the proprietary ATI drivers

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I had the same experience myself, but resolved it with a fix to an ostensibly unrelated problem. From what I understand, this is an issue with gnome-settings-daemon and mate-settings-daemon conflicting.

Follow these steps:

cd /etc/xdg/autostart/

Always backup your files, just in case:

sudo cp gnome-settings-daemon.desktop gnome-settings-daemon.desktop.bak
sudo cp mate-settings-daemon.desktop mate-settings-daemon.desktop.bak

Now start the editing:

sudo nano gnome-settings-daemon.desktop 

Then replace the text with the following:

[Desktop Entry]
Name=MATE Settings Daemon

Then edit the mate daemon

sudo nano mate-settings-daemon.desktop

Replace the line beginning with Exec= with this:

Exec=/usr/bin/mate-settings-daemon --no-daemon &

You should be set after a reboot.

share|improve this answer
Yes it works now. Thanks! –  Mertcan Ekiz Aug 23 '12 at 23:33

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.