Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was trying to install Ubuntu One client on my Windows computer, and got this:

enter image description here

I tried clicking ignore, but then there were even more errors.

share|improve this question

closed as off-topic by Eliah Kagan, Eric Carvalho, Jorge Castro, Whaaaaaat, Vojtech Trefny Sep 5 at 9:33

This question appears to be off-topic. The users who voted to close gave these specific reasons:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Eliah Kagan, Whaaaaaat, Vojtech Trefny
  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eric Carvalho, Jorge Castro
If this question can be reworded to fit the rules in the help center, please edit the question.

    
This is when you try to start the installer? Are you using a 64-bit version of Windows? –  hexafraction Aug 16 '12 at 19:55
1  
@ObsessiveFOSS Even if so, it wouldn't be referencing the 16-bit subsystem. It's a bad download. –  Eliah Kagan Aug 16 '12 at 19:58
    
@EliahKagan Ah. I am so far from Windows these days... –  hexafraction Aug 16 '12 at 19:59
    
I did try downloading it again, but it is an HTML file with an error. –  impetiredome Aug 16 '12 at 20:02
    
@iweb Yes, there is currently something wrong with the website (see this answer of mine). –  Eliah Kagan Aug 16 '12 at 20:04

1 Answer 1

up vote 2 down vote accepted

This error indicates that a DOS program is being run. Since the Ubuntu One executable for Windows (or its installer) is unlikely to have any legacy DOS components, it seems likely that the installer you downloaded is corrupted.

Just about any download can be corrupted, but the Ubuntu One installer is not very large, so the risk of corruption is usually pretty low. So I visited the download page for the Ubuntu One client for Windows, and downloaded it myself.

I examined the downloaded file (on my Ubuntu system, with file and less), confirming that it did not download correctly. Instead of the executable installer for Ubuntu One, the downloaded file was a web page!

So I renamed the file to have a .html extension, and opened it in a web browser. It looks like it might be a problem with OpenID--that, for some reason, the download page thinks you have to be logged in to download the Ubuntu One client (but downloading it while logged in doesn't work either).

I'll try to look more into this. Ultimately, it should probably be reported as a bug in the Ubuntu One website. Ordinarily we consider bugs off-topic here (reporting them, and most investigation of them), so please don't be alarmed if this question ends up getting closed.

I'm making this answer community-wiki. Anyone with information about this should feel free to edit this answer (unless moderators say not to continue work on this here, of course).

Update

I've reported this as a bug. It is bug 1037771 on Launchpad. I reported it against the ubuntuone-servers project rather than the ubuntu-website project, since the domain is one.ubuntu.com (which I believe is administered separately from the main site). I think I got the project right; if not, a triager or developer should be able to retarget it to the correct project.

I recommend subscribing to the bug (so you receive notifications about it), and indicating you are affected using the green This bug affects... link near the top of the bug page. In addition, I recommend posting your screenshot, as well as any pertinent information that I may have neglected to include, in the bug.

If you don't have a Launchpad account, you'll have to first create one in order to do this. (To do that, click Log In / Register at the upper-right corner of the main page, or any Launchpad page.) But having a second person confirm the bug on Launchpad often substantially shortens the amount of time it takes to fix important bugs like this one. (I say it's important as it is likely to affect a large percentage of users and render the product completely unusable for them; for these reasons, I believe the bug is likely to get swift attention on Launchpad, once it has been formally confirmed.)

Update 2

For the benefit of others finding this question:

The bug has been fixed, and the Ubuntu One client for Windows now downloads correctly.

Anyone who has this problem can simply re-download the installer (the proper file is currently about 20 MB large), and it should be usable.

share|improve this answer
    
Works now. Should I mark it fixed in Launchpad? –  impetiredome Aug 16 '12 at 20:55
    
@iweb No need. Roberto Alsina (Canonical employee and member of Ubuntu Bug Control) has commented and marked it as fixed. Thanks for finding this bug! –  Eliah Kagan Aug 16 '12 at 21:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.