Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have followed the tutorial here and I got everything to work but the graphics. Below is what it looks like when I play the William Wallace campaign. I need help. I really want to play the game without these wrong colors, my ubuntu version is 11.10.

enter image description here

share|improve this question
    
On that same page you linked to someone (Vndecid) had a similar issue. They said: "Open regedit HKEY_current_user->Software->wine->Direct3D and change Directdrawrender that have the opengl value for gdi" –  reverendj1 Aug 16 '12 at 20:07
    
Fire up a terminal, and use the following command: wine regedit, then navigate through to HKEY_CURRENT_USER -> Software -> Wine -> Direct3D and there should a key called Directdrawrender. Tell me what that is, then I may be able to decipher the rest of what to do. He/she did write it kind of weird... –  reverendj1 Aug 16 '12 at 20:22
    
What is the value for pixelshadermode when you click on it? –  reverendj1 Aug 17 '12 at 15:51
    
reverendj1 the pixelshadermode's value data says it is enabled. here is a snapshot i took with my vaio: img690.imageshack.us/img690/4430/screenshotat20120817122.png please reply when you can. –  hunter Aug 19 '12 at 19:19
    
i found something else: it is called "vertexshadermode" the value type is none. –  hunter Aug 19 '12 at 22:25
add comment

1 Answer

up vote 2 down vote accepted

I updated wine to 1.5.5 and this seems to have fixed the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.