Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there any edited file for draftsight.deb so it can work on ubuntu 12.04 LTS 64bit

I have downloaded the draftsight.deb from the website and tried to install it on my laptop

but I couldn't install it.

If anyone knows an edited deb file please give me the link ...

I have tried other solutions but it seems that I can't follow up with these solutions or they don't work at all

I need it for my work ... thanks anyway

share|improve this question

Assuming that it could not install due to a missing dependency? You could always extract the contents of the deb using ar and copy the files across. Once you run it you will likely be able to tell what is missing. There are other ways to find dependencies that would be more definitive, but they are more involved.

share|improve this answer
I tried that and failed to do it right... Finally I installed the draftsight for windows using Wine It worked but I am not satisfied ...It is just a trick to keep going but not a solution – LO11CH Aug 16 '12 at 20:16

Try sudo dpkg -i draftsight.deb.

share|improve this answer

Draftsight is only available in 32-bit edition (14/01/2014, V1R4 beta). Here is a workaround for the 12.04 edition. Reference can be found in and 1) Install depending packages:

sudo apt-get install libdirectfb-extra libxcb-render-util0 libgtk2.0-0:i386

2) Then force the system to install draftsight anyway:

sudo dpkg -i --force-architecture,depends draftSight.deb

Works for me in Xubuntu 12.04 (64bit)

share|improve this answer

First of all you need remove dependency in control file according to this instruction removing dependencies from draftSight.deb I instaled DraftSight, but it didn't start with messages about libraries (libGL, libGLU) then I run:

sudo apt-get install libglu1-mesa libglu1-mesa-dev ia32-libs

now it works fine.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.