Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Specifically, what are the login credentials I need to provide?

Details: The machine I want to access is running Windows 7, and I'm sure the folder sharing is working as other Windows machines can access it. In Ubuntu, I can go to Places -> Network and i see the machine there and open it, when I try to view the shared folder it will prompt me for Username/Domain/Password.

Are these credentials supposed to be my login details on the other machine? My account there does not have a password though, should I leave it blank? I'm also not clear what "Domain" needs to be.

share|improve this question

3 Answers 3

up vote 4 down vote accepted

Your login should indeed be your login on the remote machine.

There is no way to allow general access to your home folder over the network without a password. If you want full access to your home folder, you must give your account a password. You can leave automatic login turned on if you simply don't want to type a password at startup.

You can, however, allow access to the Public directory in your home directory without requiring login. To do that, go to Network and Sharing CenterChange advanced sharing settings, turn on Public folder sharing, and turn off Password protected sharing (located under the Advanced Sharing Options section near the bottom).

The domain, if this isn't on an ActiveDirectory domain (which seems likely, since your account has no password), should be either blank or the word WORKGROUP in all caps.

share|improve this answer
    
This worked. Thanks! –  Roy Tang Aug 10 '10 at 20:03
    
this saved me, many thanks ! –  BiAiB Aug 15 '13 at 12:35

Type

sudo smbpasswd -a "username"

where "username" is the login username, ex:

sudo smbpasswd -a abc

you will be asked for a password. This will create the login id and the password that you need inorder to open the file on the network.

share|improve this answer

Wild guess... but have you tried the user guest, invitado or whatever is the name of the windows guest user in your language?.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.