Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I replaced my graphics card with an Nvidia GT620. However, when I rebooted with the new card, my onboard Intel audio device disappeared completely - does not even appear in lshw.

Now the only audio output is the HDMI audio on the Nvidia card, which is annoying as my monitor has speakers but no headphone jack.

How can I make the HDMI audio device go away, and get back my onboard audio?

Sound Settings Screenshot

Sound-related stanza in lshw:

       *-multimedia
            description: Audio device
            product: GF108 High Definition Audio Controller
            vendor: NVIDIA Corporation
            physical id: 0.1
            bus info: pci@0000:02:00.1
            version: a1
            width: 32 bits
            clock: 33MHz
            capabilities: pm msi pciexpress bus_master cap_list
            configuration: driver=snd_hda_intel latency=0
            resources: irq:60 memory:fccfc000-fccfffff

Output of "aplay -l":

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
  Subdevices: 0/1
  Subdevice #0: subdevice #0

Output of sudo lspci | grep Aud

02:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
share|improve this question
    
Found this question, going to take a peek in the BIOS. askubuntu.com/questions/138907/… –  Graham Aug 16 '12 at 16:12

2 Answers 2

up vote 3 down vote accepted

The cause of the problem was that the Onboard Audio was set to "Auto" in the BIOS: meaning when the BIOS detected the HDMI audio controller, it disabled Onboard Audio.

Setting Onboard Audio to "On" caused the Onboard Audio controller to reappear in Ubuntu alongside the HDMI Audio.

share|improve this answer

I think this might be your problem.

configuration: driver=snd_hda_intel 

Try this repository. It's a bit more up to date than what's in synaptics

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update

Let us know if it does not solve the problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.