Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

About two updates ago, everything with brightness was working perfect!

But since then, the Function keys for brightness(Fn + up and Fn + down) are not working... I mean the brightness reduces only till 1 step using the keys and after that its locked.

Also, when I go to the brightness settings and reduce the brightness, this is what happens:

  • The brightness is reduced. I close the settings.
  • When I start brightness settings again, the brightness is at the set level BUT the arrow on the scroller/scale is at full!
  • I click anywhere on the scale, the brightness suddenly increases to full and then starts reducing.

Also the brightness level is not remembered after restarting from Hibernation and/or suspend. What is wrong all of a sudden? I am using Ubuntu 12.04 LTS with Unity 3D on Samsung NP-RV 509

And I have Samsung slow down manager and Samsung tools installed. (They make the function keys and stuff work on Samsung hardware properly. It is similar to the software provided by Samsung for windows.)

share|improve this question
    
have you try Fn + up and down arrow ? –  santosamaru Aug 20 '12 at 16:42
    
@santosamaru...Yeah i have those... –  Nirmik Aug 20 '12 at 17:29
    
@con-f-use...all the other Fn keys are working. –  Nirmik Aug 20 '12 at 17:29
    
Please share the content or output of the following commands/files to better help us troubleshoot your problem (instructions in this answer): file(s): command(s): lsmod –  izx Aug 21 '12 at 20:20
    
check your keyboard layout –  user61928 Aug 22 '12 at 13:40
show 3 more comments

3 Answers

Changing a line in /etc/default/grub fixed my problems for me (I'm running Ubuntu 12.04 on a Samsung QX411). You could try it.

EDIT: To test below without completely updating grub, reboot and hit e when you see the grub menu. Then just add the acpi_osi= after the quiet splash boot option and execute (cntl+x, I think)

Change:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

Then do sudo update-grub and reboot

Here's a reference for the fix: What does the kernel boot parameter "set acpi_osi=Linux" do?

share|improve this answer
    
umm...how does grub hav to do anything here? –  Nirmik Aug 30 '12 at 15:34
    
it's a kernel issue. You have to pass the right commands to the kernel. acpi_osi= basically makes the kernel tell the bios it's not running linux. I'll find the references and edit my answer –  Ian B. Aug 30 '12 at 20:01
    
there is no file like grub in there....there is grub.ucf-old and a burg file...*NOTE-i was using burg earlier when i had dual boot –  Nirmik Aug 31 '12 at 18:37
    
I don't know anything about burg, but do you know if you're running grub? If you are, see my edits above to test if the boot option will even work. On my computer, grub.ucf-old looks like just a backup file for the /etc/default/grub, so you may be able to just rename... however, you should probably be VERY careful and know exactly what's going on first. –  Ian B. Aug 31 '12 at 23:19
add comment

Could you try this command?

sudo setpci -s 00:02.0 F4.b=C5

It's not persistent.

share|improve this answer
    
its not working!! nothing happened and the brightness thing is still stuck! :( –  Nirmik Aug 24 '12 at 19:03
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.