Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Asus U47A Laptop with no discrete graphics. UEFI is disabled in the BIOS. I had Windows 7 installed by default. So, I installed Ubuntu 12.04 by creating a separate 300GB partition. During the installation, it asked me where to install the bootloader.

So, I installed the bootloader on /dev/sda option which selects my entire hard disk I guess. I was also asked to create a separate 1MB BIOS Grub partition before proceeding but I choose to ignore it cause I had the UEFI boot disabled. Now, after installation, the system just loads Windows 7.

I cannot see the Ubuntu grub/login screen. So, I went to the BIOS and saw that under boot options, it is still set to Windows bootloader option. So, what do I do now? Should I change the boot entry in the BIOS? If so, then to what (Windows recognizes the new Linux partition as 'D' Drive)?

I don't want to remove Windows but dual boot. Any help would be really appreciated.

Output of sudo fdisk -l:

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! 
The util fdisk doesn't support GPT. Use GNU Parted.
Disk /dev/sda: 750.2 GB, 750156374016 bytes
255 heads, 63 sectors/track, 91201 cylinders, total 1465149168 sectors
Units = sectors of 1 * 512 = 512 bytes

Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0x2902cc6d
   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  1465149167   732574583+  ee  GPT

Partition 1 does not start on physical sector boundary.*

share|improve this question
    
Can you add the output of sudo fdisk -l –  Mitch Aug 16 '12 at 12:48
    
Well, I could not log into the Ubuntu 12.04 I had installed as the grub screen was not displayed. So, I ran a liveCD and used the terminal and this is the output that I got: –  Jayneil Aug 16 '12 at 13:21
    
I guess the problem is because I have Windows booting in EFI mode(I ran bcdedit from command prompt in Windows and figured it out). So, can anyone please tell me how to install Ubuntu 12.04 on a UEFI enabled laptop? –  Jayneil Aug 16 '12 at 21:32
add comment

1 Answer 1

up vote 0 down vote accepted

Here is what worked for me:

So, Windows was installed in EFI mode. The Asus BIOS supported both the legacy boot and UEFI boot. So, the aim was to install both Ubuntu and WIndows in the same boot mode. There are instructions to install Ubuntu in UEFI mode but I was not feeling confident to take that approach. So, I took the latter one and dual booted Windows and Ubuntu in legacy mode.

Warning: You will format your entire computer. So, make sure to make the back up discs and take the necessary back up. If GPT partitioning or UEFI boot is important to you, then this method is not for you!

Steps:- 1. Go into BIOS and disable UEFI. Save settings and restart and go into BIOS again.

  1. If somewhere there is a setting to delete boot options then delete all the boot options. Else skip this step. Even though I am pretty sure that you cannot delete CD/DVD from boot option but if you can then don’t do it. Save all settings and restart and go into BIOS again.

  2. Put your windows DVD in the optical drive.

  3. Somewhere (mostly on the last tab of your BIOS if it’s an Asus laptop) you will find an option for boot override. Select your DVD drive and press enter. Remember that this boot over ride option should NOT contain UEFI in it’s name.

  4. You will now boot from windows DVD non-UEFI mode.

  5. During windows installation select “custom install” and then delete all existing partitions on your harddisk. Create partition for windows. When creating this partition windows will automatically make another small partition of about 100MB size as system reserved. Leave the rest of the unallocated space for now. We will take care of that space while installing Ubuntu. Install windows now.

  6. Now even after deleting all the partitions , there will be still some GPT data left on the hard drive. As, long as you don't remove it, Ubuntu won't recognize your windows installation. So use a utility called 'fixparts' and delete all the GPT data.

  7. Once that is done put your Ubuntu CD in the drive and boot from it again.

  8. During installation of Ubuntu select the option “do something else” and create a primary partition for Ubuntu.

  9. Now after creating partition for Ubuntu click on the rest of the unallocated space and click on create new partition again. But this time selected extended partition.

  10. Once you create extended partition you should be able to see all your unallocated space in a sub menu under this newly created extended partition. In this unallocated space you make rest of your partitions like linux-swap (necessary for linux to work efficiently and for hibernate to work correctly) and other partitions for your data.

  11. Make sure that the bootloader device is sda without any partition number after it.

  12. Proceed with installation. If everything goes well you should be able to dual boot to both Ubuntu and Windows.

Note:- For hibernation/trackpad/other issues , I suggest running Kernel 3.5 or above as it includes a lot of fixes. Also, intel rc6 graphics power saving option was disabled by default for me. So, enabling it boosted battery life by 2 hours!!

I hope this helps someone.

Big thanks to Bhaismachine and Rod smith for their help!!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.