Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i want my mp3-Player to work as MTP.
Therefore I added a .config containing

options usb-storage quirks=054c:059b:i

file to /etc/modprobe.d. To prevent the device from beeing auto-mounted.
Furthermore I installed mtp-tools libmtp-runtime libmtp9 libmtp-dev libmtp-dbg from the reps. Then I rebootet, plugged in the device. It didn't get mounted but was displayed with lsusb, so I tried mtp-detect:

$mtp-detect
libmtp version: 1.1.3

Listing raw device(s)
   No raw devices found.

(same with sudo)

So I copied the the 69-libmtp.rules from the latest libmtp-Package on sourceforge to /etc/udev/rules.d and added the lines

# Sony NWZ-E363
ATTR{idVendor}=="054c", ATTR{idProduct}=="059b", SYMLINK+="libmtp-%k",
ENV{ID_MTP_DEVICE}="1", ENV{ID_MEDIA_PLAYER}="1"

After that I rebootet again and I tried mtp-detect again. But without any success.

share|improve this question

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.