Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to get a private cloud running in a test environment with the use of virtual box, there have been a number of sites I have seen where this is a possibility. If this test is successful it's a real possibility that my organization would deploy this in a true production environment.

5 - VirtualBox VM's (I realize I will need to add two more nodes before I can truly use openstack, but I need one working node before I start anything else.... Servernames:

  1. server-maas1 (Maas master)
  2. server-maas2
  3. server-maas3
  4. server-maas4
  5. server-maas5

I have manually booted each VM node with 12.04 ISO, and selected Ubuntu with maas, followed the normal steps, and enlist with server-maas1 (which it does discover server-maas1) Once selected it sigkills and shutdowns. (This I gathered is normal) Server-maas1 updates to display the node declared (I have done this on the other 3 nodes as well) So server-maas1 indicates I have 4 nodes, but never seen.

I proceed to accept and commission each node, as well as change to wake-on-lan. Note: I am not using maas-dhcp, as there is a DHCP server running on my current network. All nodes are in a "commissioning" state. None of the node detail pages contains a "start node" button to try to PXE boot these VMs.

All of these VirtualBox VMs are in fact using bridged adapter (and Promiscuous mode set to Allow All, Boot Order indicates Network boot first, Adapter type (Intel Pro/1000 MT Desktop (82540EM).

At this stage I am pretty much stuck. So moving forward a few steps:

Juju is running on server-maas1, here are the .juju/environments.yaml settings:

evironments:
 maas:
   type: maas
   maas-server: 'http://172.16.41.12:80/MAAS'
   maas-oauth: 'My API Key'
   admin-secret: 'nothing'
   default-series: precise

I get a 409 error after trying to bootstrap this. I assume this is a because of more than one reason. DNS settings of some sort? Nodes are not working with MAAS correctly etc.

I believe most of my problems are caused by not running maas-dhcp, but I do not have the luxury to run maas-dhcp on this environment. According to this https://wiki.ubuntu.com/ServerTeam/MAAS, under the heading "Installation and initial set-up"

How you install and run MAAS depends largely on whether you have control of the network you're using.

In this guide, we'll look at two common scenarios:

You own the network: you own the network you're connecting to and you're happy to let MAAS own that network's DHCP. You're experimenting while using someone else's network: you can't allow MAAS to own the network's DHCP. We'll look at both of these ways to run MAAS.

Well the "You're experimenting while using someone else's network:" is never explained. Is this not an option right now?

share|improve this question
    
I have gotten around this problem by creating a host-only network in Virtualbox. You put the MAAS server and all of the nodes into the host-only network. To get internet access, use a VM appliance, like Untangled, and point the MAAS server at that router as the gateway and DNS server. Then you have an isolated network that you "own" and you can run maas-dhcp. Configure maas-dhcp to hand out the IP address of your VM router as the default gateway, but let MAAS handle dhcp and dns. –  Ian D. Rossi May 3 '13 at 19:29

1 Answer 1

To answer the booting question: You can't use Wake-on-LAN for virtual machines, you have to configure something else to start them up. MAAS supports "virsh" at the moment but I don't know if this works for Virtualbox.

The DHCP question: Yes you have to configure a DHCP server on your network because it tells the hardware how to PXE boot (simulated PXE on VMs). If you look at the files in /etc/cobbler you'll see templates for dhcp (for the isc and dnsmasq servers) which should give you a hint on how to set it up but basically the DHCP server needs to set the "filename" (which is the pxelinux.0 image) and the "next-server" which is the location of the TFTP server. next-server should be the same as your MAAS box.

When commissioning is finished, the VMs will "power off" and they'll be marked "ready" in MAAS and you can then juju bootstrap which will allocate one node, start it up and install a new OS.

share|improve this answer
    
There are two $next_server variables - which one should be edited? –  Jeremy Hajek Apr 15 '13 at 18:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.