Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm experiencing MaaS using VirtualBox. I had the MaaS server installed fine based on the wiki. The VirtualBox VM has two network interfaces, eth0 for NAT, eth1 for Host Only. The MaaS server picked eth0, so I followed the wiki instruction to change the MaaS server IP address via the following command,

sudo dpkg-reconfigure maas

The https://wiki.ubuntu.com/ServerTeam/MAAS instruction says "You will be prompted for the correct IP address", but I did not get any prompt.

I was able to manually edit /etc/cobbler/settings to change the "server" and "next-server" properties to point to the IP for eth1. The added node was able to boot via PXE that leveraged the MaaS server; however, at the end of the boot, the iscsistart is still trying to connect to IP for eth0, hence, it failed to connect, since the DHCP is set to point to the IP for eth1.

Can you help to point out 1) why I didn't get the prompt? 2) how to manually change IP address setting for the iscsi?

share|improve this question

2 Answers 2

On Ubuntu 14.04 Server

sudo dpkg-reconfigure maas-cluster-controller
sudo dpkg-reconfigure maas-region-controller
share|improve this answer

Running these commands should do it:

sudo dpkg-reconfigure maas
sudo maas-import-isos --update-settings
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.