Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I installed 10.10 a few days ago. The only changes to the default install are the addition of Chrome and Pinta.

It was fine for a few days, then today login etc seemed slow. Likewise it couldn't even render the restart/shutdown menus.

Hoping it was some botched update, I ran the update manager; it tried to install but failed (the UI didn't make it obvious what had failed).

Fine, ok. Shut it down (press enter on the blank shut-down dialog).

Fire it up hoping... And... #fail.

Target filesystem doesn't have requested /sbin/init.
No init found. Try passing init= bootarg.

Is it now a brick?

More details:

GRUB 1.98+20100804-5ubuntu3


Ubuntu, with Linux 2.6.35-22-generic


udevadm trigger is not permitted while udev is unxonfigured
Giving up waiting for root device.


Ubuntu, with Linux 2.6.35-23-generic


mount: mounting /dev on /root/dev failed: No such file or directory

Then the same for /sys and /process

share|improve this question
/sbin/init is the first thing the kernel looks for on the root filesystem. This message in fact shows (99.999% of the time) that the root filesystem couldn't be mounted (or maybe that the wrong filesystem was mounted). What are the previous few messages? If you don't see many messages, press the Shift key as soon as the BIOS has initialized the keyboard and hold it until you see the Grub menu. On the linux line, remove quiet splash, then try booting. – Gilles Dec 15 '10 at 22:39
@Gilles I think it was failure to mount; I will need to swap disks again to capture it... – Marc Gravell Dec 15 '10 at 23:32
Oh, if you have multiple disks, describe your disk layout precisely. Did you move disks around between the installation and your latest attempts? Is there any possibility of flaky hardware (loose cable, bad RAM, etc.)? What's on the linux line in Grub (if it's a UUID, not need to copy it out)? – Gilles Dec 15 '10 at 23:58
@Gilles the disk setup is simpler than you think... One is in the machine, and the other is in an anti-static bag on my desk :) two seconds, I'll swap it and get the info. – Marc Gravell Dec 16 '10 at 0:02
@Gilles is that enough? – Marc Gravell Dec 16 '10 at 0:14
up vote 5 down vote accepted

Suggested fix can be found here:


This morning, a friend came to me with his laptop that won't boot. At every boot attempt, his Ubuntu 10.04 Lucid Lynx system outputs the following error messages:

mount: mounting /dev/disk/by-uuid/***************************** on /root
failed: Invalid argument
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /dev on /root/dev failed: No such file or directory
mount: mounting /sys on /root/sys failed: No such file or directory
mount: mounting /proc on /root/proc failed: No such file or directory

Target file system doesn't have /sbin/init
No init found. Try passing init= bootarg

Busybox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu7) built-in shell (ash)
Enter 'help' for a list of built-in commands
(initramfs) _

Booting into "Recovery Mode" as well as choosing the other kernels listed in grub didn't help at all.


  1. Boot from the Ubuntu Live CD;

  2. Open/Run Terminal;

  3. Type: sudo fdisk -l (to get the device name) then press ENTER;

    Disk /dev/sda: 250.1 GB, 250059350016 bytes 
    255 heads, 63 sectors/track, 30401 cylinders
    Units = cylinders of 16065 * 512 = 8225280 bytes
    Disk identifier: **********
    Device Boot Start End Blocks Id System
    /dev/sda1 * 1 30238 242886703+ 83 Linux
    /dev/sda2 30239 30401 1309297+ 5 Extended
    /dev/sda5 30239 30401 1309266 82 Linux swap / Solaris

    The device name for my friend's system based on the above: /dev/sda1

  4. Type: sudo fsck /dev/sda1 then press ENTER;

  5. Restart the system and boot normally.

share|improve this answer
As an addendum to this, you may need to force fsck to check again by using the f option. Eg: fsck -f /dev/sda1. – Ward Muylaert May 11 '11 at 16:43
Excellent! I was worried it wouldn't work as my Ubuntu Live DVD was a 2-years older version. – Simón Jan 4 '15 at 22:40
I am getting the error the fdisk will not work becuase of GPT partition. How to proceed? – Kalamalka Kid Jun 15 at 1:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.