Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
Grub rescue - error: unknown filesystem

I was using Ubuntu 12.04 x64 as a Virtual Box guest. Because I started with it just to do some tests, the VM was created just with 10 GB but grown fast, then I wanted resizing it. Of course, I was a fully noob... No backup before doing it.

After some reading, I thought it would be so simple as:

VBoxManage modifyhd MY_DISK.vdi --resize 81920

Unfortunately, no boot:

error: unknown filesystem.
grub rescue>

Then I tried many suggestions, including Boot-Repair as described here: grub rescue after install of Ubuntu 12.04 (dual boot).

Nothing has worked. It seens that my Linux partition isn't there anymore?! Here is the Pastebin with all the information collected by Boot-Repair.

And the last try, the GParted Live CD can't also recover any data, saying that there isn't data on any partition. Well, I should just give up? Or some way to recover this disk?

share|improve this question

marked as duplicate by jokerdino, belacqua, Ringtail, devav2, con-f-use Oct 31 '12 at 8:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers 2

First, make a backup of the current disk. While it's not clear how resizing the disk would cause this, lets hope that it's a simple problem of the partition table being out of sync with where on disk your filesystems start and stop. If it's just the partition table being out of sync, then you can correct this via testdisk by following the tutorial at http://www.cgsecurity.org/wiki/TestDisk_Step_By_Step (stop when you get to the ntfs boot sector recovery, since that's not the problem you're trying to solve).

share|improve this answer

The maximum size of a Virtual-box .vdi disk is 30 GB you you tried to set it as 80 GB , i do not really know yet how to fix this, but my guess is that you have to find some way to reset the size of the virtual-box .vdi disk down to or below the max-size limit.

share|improve this answer
1  
No. The maximum size is actually up to 2TB. –  Peachy Sep 27 '12 at 14:20
    
This is not an answer!!! –  user61928 Sep 28 '12 at 12:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.