Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've found helpful solutions to randr problems on the regular GUI (Ctrl+Alt+F7) but this question is about resizing the virtual console, which doesn't have good google results.

I've been using arandr to change VGA outputs between my 1680×1050 monitor and digital projector with I think a different ratio (definitely smaller numbers). Noticed a few quirky things like I need to resize VGA, then resize LVDS, then resize VGA again (possibly multiple repeats) to reduce the maximum screen size

Between going back and forth these two devices the most recent time I somehow reduced the resolution of the virtual console (Ctrl+Alt+F6) which I use most of the day.

The virtual console still shows up correctly on the LVDS but I'd like to change the VGA resolution so I can watch the virtual console on my monitor. It was projecting at a nice large resolution before my most recent switch to projector and back. (I even looked at the virtual console on the projector and it was large resolution.)

Any suggestions what I might need to do here? I tried xrandr --output VGA --mode 1680x1050 and got can't open display error.

Let me know if there's any other info I should give.

share|improve this question
    
ok, just figured out something which I guess should have been obvious. xrandr obviously can't run in the virtual console because there's no X there. Still don't know what to run though. –  isomorphismes Aug 16 '12 at 20:17
    
From some more googling it looks like there are various VGA options in the grub bootloader. But I've changed this virtual console resolution before (accidentally) without rebooting. –  isomorphismes Aug 17 '12 at 2:03
    
resizecons doesn't currently ship with Ubuntu (it's marked as a bug) and stty size is not the command to use either. –  isomorphismes Aug 17 '12 at 2:10
    
same problem two months ago. Perhaps this is a new 12.04 issue. –  isomorphismes Aug 17 '12 at 3:16
    
Aaaaand the problem seems to have somehow "fixed itself". Don't know what I did. –  isomorphismes Aug 23 '12 at 22:59

1 Answer 1

In Grub2, as a Linux kernel boot parameter, this is what I add to the boot line on my servers...

# It follows the format of video=conn:res[M][R][-bpp][@refresh][i][m][eDd] 
# Example:
nomodeset video=VGA:1024x768@60m   

What this says is to turn kms modesetting off... Manually set the framebuffer for port VGA to 1024x768 @60Hz with a margin. Search on the "format" above and it will explain all the options for that, as well as all the valid conn names.

share|improve this answer
    
Thanks. I can't test this but appreciate your answering. –  isomorphismes Mar 13 '13 at 16:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.