Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Ubuntu Server 12.04 onto an old HP DL320 G2. This has a ATI Rage XL video card built in. Everything seems to install okay, but I'm having problems with booting.

Once the server starts booting, the screen goes black after posting, and nothing else is displayed-- no grub menu, error messages, etc. (I left it like that all night). If I hold down the [shift] key, 'loading Grub' is displayed, but once again nothing after that.

I have read several suggestions on how to fix this (and similar problems) by modifying the /etc/default/grub file and then running sudo update-grub. How can I run update-grub if it doesn't seem to be booting all the way into linux?

I think there must be an error occurring, preventing it from fully starting. However, I can't see anything to know for sure.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Boot from the live CD. Open the terminal

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

-Press Enter - Then type:

sudo apt-get install -y boot-repair && boot-repair

The open boot repair. Perform recommended repairs. If that does not fix it then paste the link here for the boot summary.

share|improve this answer
    
That worked! However, when I rebooted after setting up my users, once again nothing was displayed. Fortunately, I should be able to do everything through SSH now. –  rkyser Aug 15 '12 at 21:00
    
Glad that I could help. –  Schweinsteiger Aug 15 '12 at 21:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.