Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is a little different then most of the questions I have seen here.

When I am at my office I keep my Lenovo Thinkpad t61p running Ubuntu 12.04 x64 connected via wired Ethernet. I also typically leave the wireless radios on. After a recent update the behavior of laptop in regards to the networks has changed.

It used to be that if the laptop had a wired connection, the wired would supersede the wireless. Now, when I get to work and plug the laptop in and power it up, it connects via wired (correct behavior), shortly after the wireless begins searching for its favorite network (also correct) but as soon as it finds a network to connect to, I lose Internet.

If I disconnect from the wireless network, leaving the wireless radios powered on, and refresh the wired connection, all is well again. Powering down the wireless radios also corrects the problem.

How can I set this up so that the wired network (if available) always has precedence over the wireless?

share|improve this question

1 Answer 1

Click on the Network Manager applet on the top panel of the screen (where you also choose which wireless network to connect to etc.).

Select Edit connections...Wireless tab → Edit... for the wireless network your notebook connects to when you lose Internet.

Go to IPv4 SettingsRoutes.... In the pop-up window, check the Use this connection only for resources on its network. Confirm your change, if you're using IPv6 you've got to do that also in the IPv6 Settings. Save settings, then disable and re-enable all networking.

Wired network should now supersede wireless network again. (It works the other way round for me - I got a wireless network with Internet and a wired without.)

(Hope I didn't misunderstand the question - I couldn't comment on your question to ask for details because I haven't got enough rep.)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.