Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Ok I have a problem every 2 times out of 3 I login (I cant be specific it fairly random) I get a Stuttering GDM warning (not the login sound just the Bell sound to wake you up) the only way to stop it is to login

I have a Fujitsu Siemens Amilo 1718 with a 2gig of memory (only hardware mod) using 10.10 Maverick and I have disabled KMS as my system was freezing as per the release notes.

The only time this has happened before on the same machine was when I gave Kubuntu a try when 10.04 came out then it happened at the login screen and at random times while listening to music in any program. By the way audio is fine as is almost everything else once I have logged in.

I would like an answer to this as I am an advocate of Ubuntu and its kind of embarrassing when the first thing that happens is *bing*.

as requested Daniel


Pulse verbose log

Not sure how useful the pulse log will be as I cant replicate the bug with a terminal open but I wouldnt be asking the question if I knew the answer so.....

Edit 24/12/2010 ......been living on cocktail sausages and pickled onions for five days now made a make shift splint with cocktail sticks..... oops so updated the alsa drivers but I still get the same message in the dmesg

No response from codec, disabling MSI: last cmd=0x10a90000

googleing it brings up a forum post from some other distro with a green logo
the only common denominator seems to be graphics ie ATI Radeon XPRESS 200M which is why I have had to turn of kms as the chip is so old that small mice try to eat the "kernel" ;) funnily enough following the bug link at the end of the post, I found a comment about "Ubuntu Black Magic" so mabey I am coming at this from the wrong angle...... Bad Joo Joo any one. I will try the second part of Daniels Fix and Update with the result.

The final Edit: (Plays air guitar) In the end neither of these solved the problem as such However I have given Roland a tick for reminding me of the solution and I gave Daniel the Bounty for the effort in trying to solve the problem.

The answer for future readers was the enable the correct HD Audio Model I found the answer back when using Karmic Koala 9.10 in this forum post Amilo Li1718 Skype - Can't get it working... the model is options snd-hda-intel model=3stack position_fix=1 enable=yes which can be added to the end of alsa-base.conf thanks all for helping and hope anyone with a similar problem will find the answer here.

share|improve this question
sounds you've been hit by a common bug with hda_intel. I'll try to find the fix for you. – RolandiXor Dec 22 '10 at 17:51
Cheers Roland ;) – Allan Dec 22 '10 at 17:59
It is not a bug in the driver per se but a hardware issue. We may be able to work around it. – Daniel T Chen Dec 22 '10 at 18:32
up vote 1 down vote accepted

I have not found the option that fixed it for me yet, but for now you can check these two links.

share|improve this answer

Please modify your question to include requested output from and

EDIT: The key here is from your kernel ring buffer:

[   96.336021] hda-intel: azx_get_response timeout, switching to polling mode: last cmd=0x10a90000
[   97.340025] hda-intel: No response from codec, disabling MSI: last cmd=0x10a90000
[   98.344037] hda_intel: azx_get_response timeout, switching to single_cmd mode: last cmd=0x10a90000

Firstly, make sure you're using the latest alsa-driver snapshot: Note that this isn't a driver problem per se but a bios+hardware+codec issue, and we may be able to work around it in the driver.

Secondly, try appending the following line to /etc/modprobe.d/alsa-base.conf and rebooting only once you've rebooted into the latest daily alsa-driver snapshot and verified it is insufficient:

options snd-hda-intel single_cmd=1
share|improve this answer
Just wanted to mention that when you download the alsa-info bash file it is in upper case so when you run the command in terminal it doesn't find it. No problem for me but a new user might not understand why its not working – Allan Dec 16 '10 at 10:49
It shouldn't. If you read the instructions at that wiki page, it notes that you should: Save it as filename "" – Daniel T Chen Dec 18 '10 at 0:33
Please leave such requests as comments to the question instead of making it an answer, thanks! :) – htorque Dec 19 '10 at 15:27
I will give it a go this evening having to use my partners vista machine at the mo I will update the question with the result tommorrow – Allan Dec 22 '10 at 19:06

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.