Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All the problems I read about were all about the sound not working when they plugged the headphones in.

I have the problem that my mic will work but the sound is still played on my built-in speakers. When I look at the sound settings, it doesn't give me any options for headphones.

I run 12.04 and never had this problem in Windows. I run it on a Acer Aspire 5920g.

Any tips or ideas will be very helpful.

share|improve this question
    
Have you checked the hardware tab in sound settings ? This lists all available devices, it may not be called just headphones but a veriation on "built in audio" –  mark kirby Aug 15 '12 at 13:16
    
Ok well i got them working, but now my speakers work as well...any ideas on how to turn them off and to leave my headphones on? –  Dave Chatelain Aug 15 '12 at 16:53

1 Answer 1

I had the same problem on my Acer 5930g. Even though I plugged in the earphones I hear the sound both in the built in speakers and the headphones.

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the commands below.

gksudo gedit  /etc/modprobe.d/alsa-base.conf

and add in this line

options snd-hda-intel enable=1 index=0 model=auto

then save and reboot.

share|improve this answer
    
But this mutes the external speaker for ever! –  Nitesh Verma Nov 19 at 10:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.