Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can create folder with special characters (example mkdir Öäväaä), but ls -l in terminal shows ??v?a?.

WinScp and mc shows it right (Öäväaä). How can i make terminal to show me right characters?

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

It depends on what terminal you're using, but if you're using the default one in Ubuntu you should be able to edit the terminal settings and change the encoding. Since it's a problem isolated to the terminal app, it's probably a setting error, and most likely encoding.

I'm not running Ubuntu right now so I'm not sure where it's located, but I'm pretty sure it's somewhere around Edit > Preferences or similar, around where you change things like background color and font for the terminal. I'd suggest switching to UTF-8 and see if that fixes your problem.

share|improve this answer
2  
That would be Terminal (I'm talking about the menu item called Terminal) > Set Character Encoding. –  Dan Aug 15 '12 at 10:58
    
Yup, that's it. –  Bob0101 Aug 15 '12 at 12:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.