Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok so, been working on this for hours now, and I haven't found anything that solves the problem yet. So, basically I have a netbook (Atom N450 processor, 1GB RAM, 10.1'' display) with windows 7 installes and decided to try Ubuntu.

The installation goes well and all, desktop looks beautiful, system runs like charm, then I have to reboot and all heads down.

GRUB loads fine, and I select Ubuntu to boot. Then nothing happens, black screen with nothing on it, Ubuntu is not loading and I have to do a hard reset to get back, but no matter how many times I try, the black screen won't change.

Except, when I plug an external monitor to it... then it loads up!!!

It's been pretty frustrating and I hope someone has some experience on this issue, Having to plug it to an external monitor every time I want to work on it is not a possibility, and so far no one seems to have the same problem. Thanks in advance!

share|improve this question
    
Does this solution help? askubuntu.com/questions/162075/… –  Dan Aug 15 '12 at 10:18
    
the "nomodeset" option does allow me to get into Ubuntu (with a change in the resolution that is). But I really don't know where to go from there. Also, my problem seems to look a lot like this one wiki.ubuntu.com/X/Troubleshooting/BlankScreen but none of the workarounds have had success with me. –  Jerryments Aug 15 '12 at 11:56
add comment

3 Answers

Problem fixed! Here is how I figured out (kinda) what was going on: After doing everything you told me to and not having any kind of success, I decided I'd fix a "minor" problem I had, which was the GRUB being in the wrong resolution.

I followed this instructions: How do I safely change grub2 screen resolution? booting on recovery and going to root terminal (also, for some reason I had to update grub in the recovery menu, otherwise nano wouldn't save the changes).

Set the resolution of the grub to 800x600 and that's it... the system boots properly now and without any kind of hassle. Thank you very much to everyone for the help! And hope this also helps someone else =D!

share|improve this answer
add comment

What kind of netbook it is (Acer, Asus ecc.)? There are issues with certain producers, you can try to load it whitout acpi (add acp=off noapic to grub when booting).

share|improve this answer
2  
Being someone new to Ubuntu, I believe it would be wise to mention the steps on how to modify the grub –  Dan Aug 15 '12 at 10:16
    
It's a LANIX Netbook unfortunetly the manufacturer's website doesn't have the model anymore (to get the full specs [only in Mexico I might add]) Forgot to say I'm somewhat of a new user, and didn't quite understand your answer (though I really apreciate it) –  Jerryments Aug 15 '12 at 10:21
    
I added something about modifying GRUB in my answer. –  bigbadonk420 Aug 15 '12 at 10:21
add comment

It sounds like the problem here is that Ubuntu is treating the external monitor as the primary one. One thing I'd like to suggest first of all is trying to find a hardware button on your netbook to switch displays. Usually there's a FN button on your bottom right that can be combined with the F1 to F12 buttons, and one of these probably has a symbol on it that means "switch display output".

If this doesn't help, my other suggestion would be to try to change Ubuntu's primary display or get Ubuntu to disable the external monitor completely.

By pressing the SHIFT key during boot, you can access the boot menu and start Ubuntu in "recovery mode", this might come in handy when you're changing system settings.

As mentioned in a separate answer here, you might want to try adding acp=off noapic to the GRUB boot line. This is usually quite simple, look out for this text in GRUB:

Press enter to boot the selected OS, 'e' to edit the commands before booting

By pressing "e", you'll get the option to add some more technical mumbo jumbo to the long line of options that are by default enabled for your boot. Adding the acp=off noapic at the end of this will do the trick.

Note that by pressing "e" and adding this, it will only apply to that specific boot. It is not a permanent change and it will not be there the next time you enter GRUB. If you want to make the change permanent, you need to edit the GRUB config files. Google is handy for this :)

share|improve this answer
    
Slight Update, the Fn+Fx keys didn't work. The GRUB workaround only made it "blink" from dark purple to black, and stood that way. After maybe 10 minutes of waiting with the black screen on, I plugged in my external monitor and voila, desktop appears on both screens. Gonna try now the primary display workaround, but not much luck so far =( –  Jerryments Aug 15 '12 at 10:56
    
Does your problem arise when you boot Ubuntu in recovery mode? –  bigbadonk420 Aug 15 '12 at 10:57
    
Well, it does load up this screen ubuntu.paslah.com/wp-content/uploads/2011/04/… I'm gonna try to initiate failsafeX to see what happens –  Jerryments Aug 15 '12 at 11:08
    
Just tried changing primary display and disabling the external monitor. No luck whatsoever =/. –  Jerryments Aug 15 '12 at 12:37
    
You could always try filing a bug report: ubuntu.com/community/report-problem –  bigbadonk420 Aug 15 '12 at 15:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.