Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

What needs to be done so that when a specific input device is plugged in via USB it is not automatically used for input by X? I still want the /dev/input/* device nodes automatically created, but don't want X to use them.

My xorg.conf currently only has sections for "Screen", "Monitor", "Display", "ServerLayout", and "Device" for my video card. There are no sections for input.

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

Input devices are now managed in /usr/share/X11/xorg.conf.d/ (in 10.04 Lucid, the directory is /usr/lib/X11/xorg.conf.d/).

This directory contains configuration rules for all your input devices:

root@3000-G530:/usr/share/X11/xorg.conf.d# ls
10-evdev.conf      50-vmmouse.conf  51-synaptics-quirks.conf
50-synaptics.conf  50-wacom.conf    60-magictrackpad.conf
  • You fist need to find your input device there, note that those files are "rules" matching a number of possible devices. 50-wacom.conf for example will handle every wacom device. Look throgh them to find which one is responsible for your device, or create your own.

To disable a device:

  • Add the option Option "Ignore" "true" to the relevant configuration file.

    Open the file with root privileges (i.e. press Alt+F2 and type gksu gedit) and add this option to the others.

Log out and back in for the changes to take effect.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.