Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've made some changes to the banshee-telepathy-extension, but I can't get it to compile on Ubuntu 12.04, even after issuing a banshee

checking for BANSHEE_1_THICKCLIENT... no
configure: error: Package requirements (banshee-1-thickclient >= 1.5.3) were not met:`

Thanks in advance. :)

PS - Full stack below:

rafael@noir:~/workspace/banshee-telepathy-extension$ ./autogen.sh 
I am going to run ./configure with no arguments - if you wish 
to pass any to it, please specify them on the ./autogen.sh command line.
Running aclocal -I .  ...
Running automake --gnu  ...
Makefile.include:66: `pkglibdir' is not a legitimate directory for `SCRIPTS'
src/Makefile.am:181:   `Makefile.include' included from here
Running autoconf ...
Running ./configure ...
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking how to create a ustar tar archive... gnutar
checking whether to enable maintainer-specific portions of Makefiles... yes
checking for pkg-config... /usr/bin/pkg-config
checking for gmcs... /usr/bin/gmcs
checking pkg-config is at least version 0.9.0... yes
checking for MONO... yes
checking for GTK_SHARP_20... yes
checking for BANSHEE_1_THICKCLIENT... no
configure: error: Package requirements (banshee-1-thickclient >= 1.5.3) were not met:

No package 'banshee-1-thickclient' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BANSHEE_1_THICKCLIENT_CFLAGS
and BANSHEE_1_THICKCLIENT_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.
share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

The extension you're trying to compile was designed in the days of Banshee 1.5.3. We are now up to Banshee 2.4.1 and the API is changed. banshee-1 is now simply banshee, and the libraries are provided by the banshee package itself.

From a fresh git clone, change occurrences of banshee-1 in configure.ac to banshee and BANSHEE_1 to BANSHEE. That will let you get past this hurdle.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.