Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This has happened to me on both the 12.04 installs I have tried.

Sometimes, maybe 3 times a day, when I switch workspaces to go to programs I leave open in other workspaces, the Window isn't there. I find them in odd positions - for example, I just found my browser window half off the bottom of workspace 4, wrapped around to partly in the top of workspace 1.

What makes it more likely to happen appears to be when a window has a child window/dialog open. The child is very likely to be displaced randomly?

Edit: have switched off all extra workspaces - now just working in one, because I got tired of hunting down lost app windows. Either no-one else is seeing this, or else no-one has any solution.

share|improve this question
    
This case occurs when your movable half window is below the screen or in other workspace , and then on clicking to maximize it allocates itself to next workspace maximized. –  atenz Aug 15 '12 at 5:14
    
No that is not what I am seeing. The window is wholly on one workspace originally, but when I switch workspaces, unity displays it in some other position, sometimes half off workspace and half on another. No maximising involved either. –  Jazz Aug 15 '12 at 5:44
2  
This is a known bug and currently being worked on: bugs.launchpad.net/ubuntu/+source/compiz/+bug/862430. –  FuzzyQ Aug 23 '12 at 9:35
    
Oh, I see. Thanks very much for the info. I will just have to wait patiently then. –  Jazz Aug 23 '12 at 11:18
1  
On further reading, I don't think it's the same bug. That seems to be mainly about 'flickering' and I think I have seen that problem as well. What I am seeing is that the window moves to a strange new place, and stays there. –  Jazz Aug 23 '12 at 11:30
show 1 more comment

1 Answer 1

I have been experiencing this bug since a long time in 12.04. A fix has been released but it may take some time before it's backported to 12.04, check out these two bug reports:

https://bugs.launchpad.net/ubuntu/+source/compiz/+bug/1037164 https://bugs.launchpad.net/compiz-plugins-main/+bug/755842

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.