Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After I installed Gnome 3, restarted, and logged back in with "Gnome" as the chosen interface. My desktop looks like this. Any solution?

enter image description here

share|improve this question

1 Answer 1

up vote 3 down vote accepted
  • From the screenshot, I see you are running Ubuntu in VMWare Player (on Windows).

  • What's probably happening is that Gnome isn't detecting 3D acceleration/support and is falling back to Gnome 2D (which looks exactly like your screenshot).

  • VMWare Player does have rudimentary 3D support, but it needs to be enabled from the settings first; see the below screenshot:

    enter image description here

  • If you can't find that option in the settings, add this line to the .vmx file:

    mks.enable3D = "TRUE"
    
  • Then restart VMWare player, boot Ubuntu, select Gnome and hopefully you'll get Gnome-Shell (3D).

share|improve this answer
    
izx, thanks for your immediate response. I am unable to locate a ".vmx" file; however, I see a ".vmxf" file in the Documents/Virutal Machines directory. For some reason, the options to select 3D Graphics and Monitors in the Display option is greyed out, so I can't change any of the settings. –  AsianXL Aug 15 '12 at 1:51
    
Nevermind, I got it to work now. Thanks! –  AsianXL Aug 15 '12 at 2:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.