Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 11.10 on my Dell Optiplex 745 today. I could not connect to the internet with the LiveCD, but I installed it anyway. It still doesn't work. This is the first time linux has been installed on this computer. Windows XP connects with no problem.

I have a Broadcom NetXtreme 57xx Gigabit Controller.

I have tried removing NetworkManager and using dhclient but it doesn't work either.

I also tried:

modprobe tg3

and then:

dhclient eth0

The last command runs forever. I dont know if thats good or bad. When I do:

ping google.com

or try to open a page with firefox, I get a connection error.

EDIT:

lspci output:

flyingfisch@Office-OptiPlex-745:~$ lspci
00:00.0 Host bridge: Intel Corporation 82Q963/Q965 Memory Controller Hub (rev 02)
00:01.0 PCI bridge: Intel Corporation 82Q963/Q965 PCI Express Root Port (rev 02)
00:02.0 VGA compatible controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:02.1 Display controller: Intel Corporation 82Q963/Q965 Integrated Graphics Controller (rev 02)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 02)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 02)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 02)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 02)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev f2)
00:1f.0 ISA bridge: Intel Corporation 82801HB/HR (ICH8/R) LPC Interface Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801H (ICH8 Family) 4 port SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 02)
00:1f.5 IDE interface: Intel Corporation 82801H (ICH8 Family) 2 port SATA IDE Controller (rev 02)
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit Ethernet PCI Express (rev 02)

EDIT2:

I don't know, maybe I am not running tg3 correctly?

When i run modprobe tg3, it does not run forever. It just finishes with no output. Like this:

# modprobe tg3
# _

dhclient loops forever though. Is that OK?

EDIT:

I booted the Ubuntu 12.04 LiveCD and it still cannot connect to the internet. I did modprobe tg3 and it didn't seem to do anything. What should I do?

EDIT:

I got a new NIC and now it works :)

share|improve this question
    
Post you lspci output –  LnxSlck Aug 14 '12 at 23:08
    
@TrailRider: ethernet. –  flyingfisch Aug 14 '12 at 23:12
    
@flyingfisch, open up a terminal, and type: lspci, put here the output given TrailRider better? :) –  LnxSlck Aug 14 '12 at 23:16
    
edited my post to show the lspci output –  flyingfisch Aug 14 '12 at 23:36
    
Anymore help on this? –  flyingfisch Aug 15 '12 at 0:44
show 4 more comments

1 Answer 1

dhclient is responsible for DHCP. Since, it runs forever, you couldn't get an IP address; hence, no connection.

For more information, use man dhclient.

Since, the problem is now resolved, there could be some problem in you NIC or the configuration of your old NIC.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.